1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Auto rotation on Fanatec Wheels

Discussion in 'Automobilista - Help & Support' started by TrintaE2, Apr 14, 2017.

  1. TrintaE2

    TrintaE2 New Member

    Joined:
    Jun 15, 2016
    Messages:
    14
    Likes Received:
    2
    @Renato Simioni

    Hello!
    I own a CSL Elite wheel base and though fanaleds now work the rotation is not automatically set. I tried changing the option to on/off, created a new controller profile and a new profile! What am I doing wrong? Alhough it's not a big issue, specially with fanatec, I would like to have such feature!

    I also noticed that i have profiles in the AMS installation folder and in the Documents folder. Which one is the game loading? Which one should i delete?
    Thanks in advance!
     
    Last edited: Apr 14, 2017
  2. diabolus79

    diabolus79 New Member

    Joined:
    Dec 27, 2016
    Messages:
    17
    Likes Received:
    3
    Make sure that you have SEN setting to Auto.
     
    • Agree Agree x 1
  3. TrintaE2

    TrintaE2 New Member

    Joined:
    Jun 15, 2016
    Messages:
    14
    Likes Received:
    2
    I have!
     
  4. Uff

    Uff New Member

    Joined:
    Mar 10, 2016
    Messages:
    16
    Likes Received:
    3
    Go to Options -> Control, you should see CSL as preset. Click on LOAD, then assign again buttons. In this way it works properly here.
     
  5. TrintaE2

    TrintaE2 New Member

    Joined:
    Jun 15, 2016
    Messages:
    14
    Likes Received:
    2
    I dont have a CSL preset! Is it this one though?

    upload_2017-4-14_22-25-13.png
     
  6. Uff

    Uff New Member

    Joined:
    Mar 10, 2016
    Messages:
    16
    Likes Received:
    3
    Uhm, I don't know then: it probably was a profile I saved before, after loading it, the steering wheel began to work. Try loading one of those to see if it makes any difference.
     
  7. baker

    baker New Member

    Joined:
    Mar 30, 2016
    Messages:
    11
    Likes Received:
    2
    Some thing here. Auto-rotation for Fanatec CSL-E does not seem to work for me.

    Edit:
    ok never mind it does work.
    I needed to load the profile clubsport wheel.. first one I think not the CSW ones or CSR.

    So thank you for this update I'v been wanting and waiting for it ever since I got this new wheel.. Very nice to have it working like this thank you. :)
     
    Last edited: Apr 16, 2017
  8. TrintaE2

    TrintaE2 New Member

    Joined:
    Jun 15, 2016
    Messages:
    14
    Likes Received:
    2
    About DOR.
    I loaded the Clubsport Wheel profile, enable custom steering rotation set to NO, i load the car and i have 1080 degrees on all cars! The on-wheel settings has sensitivity set to AUT.
    New installation?? Profiles? Any idea of what i'm doing wrong??
     
  9. baker

    baker New Member

    Joined:
    Mar 30, 2016
    Messages:
    11
    Likes Received:
    2
    I can't say for sure if this will work for you but this is what I do,
    I load into the race, practice or whatever, when I get to the garage I go into the options and set
    "enable custom steering rotation set to yes" then back out of options, then back into options and set it back to No and for some reason this makes it work for me.
     
    Last edited: Apr 23, 2017
  10. Marc Collins

    Marc Collins Active Member

    Joined:
    Mar 12, 2016
    Messages:
    318
    Likes Received:
    89
    Set in the main Settings screen after you start AMS and before you go into a race/session just in case that makes a difference.
     
  11. TrintaE2

    TrintaE2 New Member

    Joined:
    Jun 15, 2016
    Messages:
    14
    Likes Received:
    2
    i've tried that! i even reported it as bug recently! no matter what profile i load the game doesnt match the wheel rotation or vice versa! Everything is up to date!
     
  12. OlivierMDVY

    OlivierMDVY Member

    Joined:
    Aug 1, 2016
    Messages:
    95
    Likes Received:
    37
    You don't have to go out of the controler option: just set YES then NO the Custom Steering Rotation and voila :)
     
  13. TrintaE2

    TrintaE2 New Member

    Joined:
    Jun 15, 2016
    Messages:
    14
    Likes Received:
    2
    I know! And voila doesn't work! I own Automobilista since the beta. My fanatecd gt3rs worked with DOR but not this one! In the last update they started supporting the elite wheelbase but still not working for me!
     
  14. baker

    baker New Member

    Joined:
    Mar 30, 2016
    Messages:
    11
    Likes Received:
    2
    I know I heard that one too but that doesn't work for me.
    Seems sometimes I need to actually get onto the track first then back out to garage for options before it works.
    It definitely doesn't work right away and this weird setup routine I have to do each time I start the game.

    But anyway seeing I am mostly driving the super v8's I can just leave my wheel on 360 anyway.
    It is nice to have it working though when testing things with other cars.
     
  15. geg

    geg New Member

    Joined:
    Mar 9, 2016
    Messages:
    3
    Likes Received:
    0
    Same for me but with CSW V2 fresh install the game doesnt match the wheel rotation. Is reiza working on a fix?
     
  16. Luis Miguel

    Luis Miguel H. Dev Staff Member

    Joined:
    Feb 15, 2016
    Messages:
    6
    Likes Received:
    4
    Hey TrintaE2,

    I had the same problem with CSL Elite. However it started to work once I updated drivers and used the tool that comes with them to flash the latest firmware into the steering wheel. Did you do that too when you say is all up to date?

    Apart from that, Sen must be in AUTO/OFF (depending on the wheel)

    This steps should apply to any Fanatec wheel :)
     
  17. Renato Simioni

    Renato Simioni Administrator Staff Member

    Joined:
    Feb 14, 2016
    Messages:
    1,204
    Likes Received:
    3,844
    To be clear, auto rotation should be working on all Fanatec wheels so long as firmware is updated (not including Beta releases), SEN is set to Auto / OFF on wheel and "ENABLE CUSTOM STEERING RANGE" is set to NO in-game. If it isn´t, please post here so we can try investigate the issue.
     
  18. Speeddmon91

    Speeddmon91 New Member

    Joined:
    Nov 10, 2016
    Messages:
    2
    Likes Received:
    0
    CSW V1 has this issues

    Work fine going back to 1.35r of ams

    Driver Version: 261
    Firmware Version: 205

    the only way i found of getting around this issue is to manually set wheel rotation on wheel

    Cheers Demon
     
  19. TrintaE2

    TrintaE2 New Member

    Joined:
    Jun 15, 2016
    Messages:
    14
    Likes Received:
    2
    CSL Elite Wheelbase

    SEN is AUT
    "ENABLE CUSTOM STEERING RANGE" is set to NO in-game
    Driver version: 261 64BIT
    Firmware: 206
    AMS version: 1.37
    I didnt reinstall the driver but I ran firmware flash and I got the same results!
    Is there any newer version of the driver?? The latest one on their website is v261.
    It runs fine in all other sims with similar feature!

    Thanks for the effort guys!
     
    Last edited: Apr 25, 2017
  20. geg

    geg New Member

    Joined:
    Mar 9, 2016
    Messages:
    3
    Likes Received:
    0
    CSW V2
    ======
    AMS fresh install
    SEN is AUT
    "ENABLE CUSTOM STEERING RANGE" is set to NO in-game
    Driver version: 261 64BIT
    Firmware: 206
    AMS version: 1.37

    Had before 1.37 from time to time auto rotation that was not working a FFB reset always fixed the problem. Now no matter what i do the auto rotation is not working
     
    Last edited: Apr 25, 2017

Share This Page