1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Excessive Stuttering Unrelated to the PC Hardware

Discussion in 'Automobilista 2 - Help & Support' started by Georgeagea, Dec 28, 2021.

  1. Georgeagea

    Georgeagea New Member

    Joined:
    Jun 10, 2020
    Messages:
    3
    Likes Received:
    2
    *What is it?
    Excessive stuttering during a race, when there are like 10 or more players in the race. It happened in all the races after the latest big ranking update. I've not noticed any stuttering previous to that update.
    It doesn't happen during qualifying or practice.

    *How do I know it's unrelated to the PC hardware?!
    My FPS is at a constant 90+fps on a triple monitors setup. I have monitoring apps and they show a constant 90+fps and nothing abnormal from, say an offline AI race. CPU and GPU usages, temps, frame times etc... all is normal. I run also simhub and crewchief. Also as mentioned above, that issue never happened before the latest big update.

    Also, my friend runs a single monitor with a beefier PC and has the same exact stutters while having maybe 120+ constant FPS. He doesn't use any external apps like simhub or crewchief.

    *What do I think it is?
    I think it's something related to ping, latency or location.
    Both I and my friend live within minutes of each other and we face the same exact excessive, border unplayable stutter, at the same during the same lobby/race, while we have totally different rigs, PCs, performance, wheel, hardware, external apps etc... We live in the middle east, Lebanon specifically. This shouldn't be a problem since we're not far away from Europe and we play all sorts of sims and games on European servers without any issues with a ping of less than 90ms.

    *What I'm not sure about?
    Isn't this game also P2P like PC2?! Well, I and my friend had that same excessive stutter while I was once hosting a lobby! This makes me a bit lost on the whole matter... My ping bar was full green but maybe the server is actually far away?! I really dunno...
    Yesterday, out of curiosity, I jumped into Project cars 2 and a 20 cars lobby race. The experience was silk smooth.

    The issue described above will, unfortunately, mean that I and my friend will no longer be able to enjoy this game online. Yesterday I got pole with GT3s on Kyalami to later spin on the 2nd lap when the game stuttered heavily when i was mid corner...

    Devs or anyone that can help we would be thankful. Thank you.
     
  2. CrimsonEminence

    CrimsonEminence Administrator Staff Member Reiza Backer

    Joined:
    Nov 4, 2018
    Messages:
    7,518
    Likes Received:
    5,443
    Known issue, under investigation. As a workaround for now i recommend turning off "UDP" in the system settings of AMS2. (You can still use Crewchief app because it only requires shared memory to pCars2 mode).
     
    • Like Like x 1
    • Agree Agree x 1
  3. Neil D Corfield

    Neil D Corfield R3D M15T

    Joined:
    Jan 31, 2021
    Messages:
    38
    Likes Received:
    5
    Can confirm that disabling the UDP seems to have resolved it on the initial test, more test to be done but looks good. Hopefully it can be resolved as not having simhub running is not great
     
  4. Shriukan

    Shriukan Touristenfahrten Community Reiza Backer

    Joined:
    Sep 23, 2019
    Messages:
    1,264
    Likes Received:
    891
    Simhub works on shared memory as well
     
  5. dryheat94

    dryheat94 Member

    Joined:
    Sep 16, 2021
    Messages:
    54
    Likes Received:
    27
    I run Simhub with radar and a full map with no stutter issues. UDP off.
     
  6. F1Aussie

    F1Aussie Well-Known Member

    Joined:
    Mar 21, 2016
    Messages:
    1,622
    Likes Received:
    441
    Do you need UDP on if running shakers and simhub at the same time?
     
  7. Neil D Corfield

    Neil D Corfield R3D M15T

    Joined:
    Jan 31, 2021
    Messages:
    38
    Likes Received:
    5
    No, you should be okay to run bass shakers and wind through sim hub without UDP running and also crew chief, however I am unable to run UDP online racing as the stuttering occurs with more than 10 players, however most of the telemetry has been run prior to race. So I would recommend turning of only UDP and leave both Shared Memory.
     
  8. Peter Stefani

    Peter Stefani Active Member Reiza Backer

    Joined:
    Mar 3, 2020
    Messages:
    265
    Likes Received:
    170
    NOTE: If you absolutely have to capture race telemetry for a 3rd part app, then try adjusting the UDP level upwards from 1 to 4, then up to 8 and see if the stuttering is gone at one of those settings.
    The UDP data rate is being sent at maximum when the level is at 1 (yeah, sort of backwards) and the rate being sent to your router goes down as the UDP level is changed to a higher number.
    This is not really a game issue, but a mater of how your particular router can handle so much data during MP races with more than 10 cars.
    If you find that your router is overloaded with the UDP at 10, then you'll probably have to turn the UDP off during MP racing.
    And another source of stuttering can be all the Microsoft items running in background, and sending all kinds of info to Microsoft at anytime, so turn all that crap off too.
     
  9. VFX Pro

    VFX Pro Well-Known Member

    Joined:
    Mar 31, 2017
    Messages:
    603
    Likes Received:
    301
    I have the same stuttering problem during online race as well. I don't have a repeatable pattern or stats to substantiate my claim, but the worse the ping to the server the worse the stuttering is...

    I'm using SimTools for motion rig and SimRacing Studio for Buttkickers, turning off UDP is not an option for me :(
    Perhaps, other cars telemetry is clogging up the system. I hope this gets fixed soon.
     
    Last edited: Jan 22, 2022
    • Agree Agree x 2
  10. sgsfabiano

    sgsfabiano Well-Known Member Reiza Backer

    Joined:
    Oct 28, 2019
    Messages:
    1,438
    Likes Received:
    859
    Also having these annoying stutters. I have not changed anything on my system other than updated nVidia drivers - this issue has started happening before that, though.
     
  11. VFX Pro

    VFX Pro Well-Known Member

    Joined:
    Mar 31, 2017
    Messages:
    603
    Likes Received:
    301
    OK, I finally found a repeating pattern using TimeTrial. I turned off CrewChief V4 which also contains a new plugin by @toniware / @MasterLooser that provides a radar and useful fuel info and suddenly Monza and Guaporé FPS loss is gone... I don't know if it's the plugin or CrewChief yet.

    Online stuttering continues to be related to high pings.
     
    Last edited: Jan 26, 2022
  12. Vitor

    Vitor Member Reiza Backer

    Joined:
    Jun 25, 2016
    Messages:
    68
    Likes Received:
    17
    Neither crewchief not toniware’s spotter use UDP.
     
  13. VFX Pro

    VFX Pro Well-Known Member

    Joined:
    Mar 31, 2017
    Messages:
    603
    Likes Received:
    301
    Perhaps it's not UDP related, but very likely CrewChief and toniware's spotter related.
     

Share This Page