1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Game freeze 3 out 4 times when entering track in single player

Discussion in 'Automobilista - Help & Support' started by Wergilius, May 1, 2018.

  1. Wergilius

    Wergilius Member

    Joined:
    Dec 24, 2017
    Messages:
    33
    Likes Received:
    14
    (not sure if this an bug or an feature in my system so I post it here)

    Track & Layout Used: Any

    Car Used
    : Any

    Applicable Settings
    : Single player only, during single event or championship

    Report
    : When entering the track with the ">" button in any single event in single player 3 out 4 times AMS freezes, current sound continues to loop. Alt+tab do not work, only ctrl+alt+del. Starting task manager and then kill AMS is the only solution. When using the task manager, mouse is not working. Normally when using alt+tab, mouse is working.

    The freeze normally happens at first try, but could also happen on 2nd or later try during qualify or when starting the race if qualify session ends.

    This happens 3 out 4 tries during single player, it has never happen during multi-player. I have now instead started create an LAN multiplayer session with AI and so far it has not happen for 10 races.

    I have verified AMS thru steam, deleted the Automobilista folder in my documents creating a new profile, tried low postFx audio settings but any of that did not make any difference.

    Steps to reproduce: Start any single player event


    Suggestions welcome :)
     
  2. Wergilius

    Wergilius Member

    Joined:
    Dec 24, 2017
    Messages:
    33
    Likes Received:
    14
    I have now deleted everything an re-installed AMS, no sweetFX, no spotter, new profile.

    Attaching and trace files, this time it did work to enter the track once, on 2nd time AMS freeze when ">" to enter the track was clicked.

    From track.txt:
    (when ok)
    09:47:08: options.cpp 228: OPT:: To track from monitor
    09:47:08: plrfile.cpp 2177: PLR saving...
    09:47:08: plrfile.cpp 2206: Attempting to save to C:\USERS\JENS\DOCUMENTS\AUTOMOBILISTA\USERDATA\Jens Roos\Jens Roos.TMP
    09:47:08: plrfile.cpp 2247: PLR saving career
    09:47:08: plrfile.cpp 2275: PLR saving career 0
    09:47:08: plrfile.cpp 2239: Retcode: 0 for renaming to C:\USERS\JENS\DOCUMENTS\AUTOMOBILISTA\USERDATA\Jens Roos\Jens Roos.PLR
    09:47:08: hwinput.cpp 3212: FFB:: Restart... Current Value 1
    09:47:08: hwinput.cpp 5849: FFB Post: getting lock
    09:47:08: hwinput.cpp 5889: FFB Post: releasing lock
    09:47:08: hwinput.cpp 3219: FFB:: locking
    09:47:08: hwinput.cpp 3227: FFB:: releasing lock
    09:47:08: options.cpp 286: OPT:: Restarting FFB
    09:47:08: hwinput.cpp 3212: FFB:: Restart... Current Value 1
    09:47:08: hwinput.cpp 5849: FFB Post: getting lock
    09:47:08: hwinput.cpp 5889: FFB Post: releasing lock
    09:47:08: hwinput.cpp 3219: FFB:: locking
    09:47:08: hwinput.cpp 3227: FFB:: releasing lock

    (when it freezed)
    09:50:52: options.cpp 228: OPT:: To track from monitor
    09:50:52: plrfile.cpp 2177: PLR saving...
    09:50:52: plrfile.cpp 2206: Attempting to save to C:\USERS\JENS\DOCUMENTS\AUTOMOBILISTA\USERDATA\Jens Roos\Jens Roos.TMP
    09:50:52: plrfile.cpp 2247: PLR saving career
    09:50:52: plrfile.cpp 2275: PLR saving career 0
    09:50:52: plrfile.cpp 2239: Retcode: 0 for renaming to C:\USERS\JENS\DOCUMENTS\AUTOMOBILISTA\USERDATA\Jens Roos\Jens Roos.PLR
    09:50:52: hwinput.cpp 3212: FFB:: Restart... Current Value 1
    09:50:52: hwinput.cpp 5849: FFB Post: getting lock
    09:50:52: hwinput.cpp 5889: FFB Post: releasing lock
    09:50:52: hwinput.cpp 3219: FFB:: locking
    09:50:52: hwinput.cpp 3227: FFB:: releasing lock
    09:50:52: options.cpp 286: OPT:: Restarting FFB
    09:50:52: hwinput.cpp 3212: FFB:: Restart... Current Value 1
    09:50:52: hwinput.cpp 5849: FFB Post: getting lock

    So could it be FFB related (using OSW & SimuCube)?


    One note, if I create an LAN Multiplayer it works without any problem to enter the track, not an single freeze since May!
     

    Attached Files:

  3. sherpa25

    sherpa25 Member

    Joined:
    Mar 11, 2016
    Messages:
    114
    Likes Received:
    3
    Do you have Power Management mode in Nvidia Control Panel set to 'Prefer maximum performance'?
     
  4. Wergilius

    Wergilius Member

    Joined:
    Dec 24, 2017
    Messages:
    33
    Likes Received:
    14
    Yes, i'm running 1080ti sli / triples & simucube osw

    I have another problem, even when starting with lan mp I can only do shorter racers (my guess around 20m). I have now done several 45m & 1 hour races (with AI), a little while after the finish line but before all AI is back in pit, AMS crash to desktop. No result is saved.

    This has happens 4 out 4 times (on official content). Have done several 45m or longer online races without any problems.

    Maybe I'll do a longer run with trace on or do an single player race but then I would need two successful entering the track in a row..
     

Share This Page