1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rainy weather game crash

Discussion in 'Automobilista 2 - General Discussion' started by Viking_Magnus, Mar 18, 2020.

Tags:
  1. Viking_Magnus

    Viking_Magnus Member Reiza Backer

    Joined:
    Mar 13, 2020
    Messages:
    69
    Likes Received:
    32
    Hey everyone,

    Since the Beta 3 update (or perhaps its follow up extra patch), I have been unable to launch any race that includes a form a rain. Whether it is "Rain", "Storm" or anything else that includes rain at all, the loading bar gets roughly half way before it crashes back to desktop.

    I have submitted a crash report using the crash report tool, but I was wondering, is anyone else having the same issue?

    (I purchased the Beta after the Beta had begun, so I unfortunately don't have access to the Beta forums to check if it's been reported)
     
  2. Mad Al

    Mad Al Member Reiza Backer

    Joined:
    Jun 30, 2019
    Messages:
    67
    Likes Received:
    32
    Try a delete (or rename) of the Automobilista 2 folder in Documents and verify the integrity of the game files in Steam
     
    • Winner Winner x 1
  3. Viking_Magnus

    Viking_Magnus Member Reiza Backer

    Joined:
    Mar 13, 2020
    Messages:
    69
    Likes Received:
    32
    I'd done the verify integrity, but not the deleting folder tip yet, thanks! I'll give it a go and report back whether it works.
     
  4. Viking_Magnus

    Viking_Magnus Member Reiza Backer

    Joined:
    Mar 13, 2020
    Messages:
    69
    Likes Received:
    32
    Confirmed, deleting the Automobilista 2 folder in Documents forced it to be recreated upon next launch. Now wet weather works! Thanks so much :)
     
    • Like Like x 1
  5. Gevatter

    Gevatter The James May of Simracing Reiza Backer

    Joined:
    Mar 10, 2016
    Messages:
    431
    Likes Received:
    216
    I don't use rain that much, but I had the same issue some days ago in Beta 3. I got it working after starting on a dry track first, then exiting out and setting rain.
     
  6. Viking_Magnus

    Viking_Magnus Member Reiza Backer

    Joined:
    Mar 13, 2020
    Messages:
    69
    Likes Received:
    32
    Curiously I have started getting the same issue again. But this time the "deleting the folder & verifying game files" trick doesn't fix it.

    Hopefully the next beta patch fixes it
     
  7. Mad Al

    Mad Al Member Reiza Backer

    Joined:
    Jun 30, 2019
    Messages:
    67
    Likes Received:
    32
    Before doing anything else... add a folder exception to your antivirus to include the Automobilista 2 folder in Documents and the install folder for the game... just to make sure it's not the AV ****ting on the game files/blocking things

    You might also like to add your PC specs to your signature.. :)
     
  8. Viking_Magnus

    Viking_Magnus Member Reiza Backer

    Joined:
    Mar 13, 2020
    Messages:
    69
    Likes Received:
    32
    Just to confirm, this issue is still happening for me in Beta 4

    - Deleting the AMS2 folder in My Documents then verifying file integrity didn't fix it
    - Launching a Clear weather session, exiting, and attempting wet, didnt fix it
    - Adding an exception in my AV didn't fix it

    Any other options?

    Or more importantly, can anyone confirm the issue has been recognised in the Beta forums?
     
  9. Marc Collins

    Marc Collins Well-Known Member Reiza Backer

    Joined:
    Mar 12, 2016
    Messages:
    3,409
    Likes Received:
    1,235
    Is it Race session only, or also P and Q? And all/any track? And if Race only, are you running P or Q first? Does it happen in Test Day?

    I have read all the beta threads and this is not a general issue that I am aware of.
     
  10. Viking_Magnus

    Viking_Magnus Member Reiza Backer

    Joined:
    Mar 13, 2020
    Messages:
    69
    Likes Received:
    32
    So far I haven't been able to narrow it down. I was primarily doing Test Days, and it would crash any track/car combo I tried there.
    From your post I decided to try a Race, with Practice (which I skipped), and it worked perfectly fine then.
    After that, I have gone back to Test Days, and it has worked perfectly ever since.

    So I have no clue how to diagnose it, but its working now so I guess that's all that matters :)

    (I was submitting the bug report with the tool from the crashes, so perhaps the devs can see what the problem was anyway)
     
  11. Marc Collins

    Marc Collins Well-Known Member Reiza Backer

    Joined:
    Mar 12, 2016
    Messages:
    3,409
    Likes Received:
    1,235
    I think there are wet tire issues that are causing crashes--e.g., I have reported ARC Camaro causes crash any time wet tires are installed on it in the pits (after entering pits on dries). When you jump straight into a race, there must be some confusion/missing pieces somewhere that crash it.
     

Share This Page