1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windowed not true color?

Discussion in 'Automobilista - General Discussion' started by shangerdi, Aug 25, 2016.

  1. shangerdi

    shangerdi New Member Reiza Backer

    Joined:
    Jun 27, 2016
    Messages:
    7
    Likes Received:
    1
    I found the color in windowed mode seems like 16 bit color even with 32 bit selected in config.
    The full screen mode is OK.
    Windows 10 system. Is there anyone the same?

    This issue had been fixed. Thanks!

    upload_2016-8-26_0-50-26.png
     
    Last edited: Sep 4, 2016
    • Agree Agree x 1
  2. xnorb

    xnorb Active Member Reiza Backer

    Joined:
    Mar 10, 2016
    Messages:
    168
    Likes Received:
    103
    I'm running AMS windowed (borderless) on Win10 and it's all fine.

    But several updates in the past have done that to me too.
    Solution for me: Delete config.ini
    Other member suggested: Create new profile
     
  3. shangerdi

    shangerdi New Member Reiza Backer

    Joined:
    Jun 27, 2016
    Messages:
    7
    Likes Received:
    1
    Thanks a lot! Delete config.ini will work for that.
    But I think the "AMS Config.exe" maybe have a small issue. Only the first time config is OK.

    My first time config setting is:
    upload_2016-8-26_19-51-10.png

    But if I run "AMS Config.exe" again it will be like this:
    upload_2016-8-26_19-53-12.png

    And then I change the resolution to "2560x1600 32 bit" as before and save and go into game, the color issue happened.

    Here is the config.ini files compare:
    upload_2016-8-26_19-58-34.png

    The problem is caused by reading and writing the Video Mode.
    Thanks xnorb again and wish Reiza will fix this little issue when idle.
    Thanks Reiza's great work!
     
    • Like Like x 1
    • Informative Informative x 1
  4. hex

    hex Damage, Inc. Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    162
    Likes Received:
    108
    It does make sense. I remember long time ago (with gSCE) I had a problem like that, and had to manually change the video mode to "46" to have beatiful and smooth skies, but this method does not work anymore - AMS config reappears and goes back to "22".

    I mentioned it here
     
    Last edited: Aug 26, 2016
  5. Nobkins

    Nobkins Active Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    136
    Likes Received:
    51
    This worked for me with V1.02 (I think that is version number). Same again I am getting reset to video mode 41 from mode 84 if I launch the config tool a second time, change nothing but click ok. @Renato Simioni there appears to be a bug with the config tool relating to 16bit color and the videomode setting.
     
  6. Alex Sawczuk

    Alex Sawczuk Well-Known Member Reiza Backer

    Joined:
    Feb 14, 2016
    Messages:
    1,029
    Likes Received:
    858
    Hi, I also had the issue and we think we've been able to fix it. Should be in the next release.
     
    • Like Like x 4
    • Informative Informative x 1
  7. shangerdi

    shangerdi New Member Reiza Backer

    Joined:
    Jun 27, 2016
    Messages:
    7
    Likes Received:
    1
    Great! Thanks a lot!
    I was always kicked to the Win desktop by some ugly software(like win+D switch to Desktop). So the windowed mode is important for me. But I realized that some of games in fullscreen will not. Are they able to anti switched to Desktop?
     

Share This Page