1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Inconsistent Frame-rates

Discussion in 'Automobilista 2 - General Discussion' started by Andrew Hollom, Nov 15, 2020.

  1. Andrew Hollom

    Andrew Hollom Active Member

    Joined:
    Mar 9, 2019
    Messages:
    166
    Likes Received:
    60
    What started off as a comparison between the 911 Cup cars of rF2, AC, ACC, AMS2 and PC2 got me wondering if there's a problem with (possibly) thread allocation in the Madness engine, as I got very inconsistent results from both AMS2 and PC2.

    I was driving around Brands Hatch in the 911 Cup cars and couldn't manage 72 fps from AMS2 (with the settings mostly on low), so I tried PC2 and got 72 fps (also mostly on low), but when I hit escape and then Resume, it dropped to 36 fps. Doing this in AMS2 didn't result in it varying from 36 fps (but see Restart Session below).

    I then tried Londrina in the 911 Cup and got 36 fps, then switched to the P3 Duratec and got 72 fps, so thought it must be the car. I then went back to the 911 Cup and started to adjust some settings (I turned Bloom, Heat Haze and both Sun Flares off) and got 72 fps. However, I sometimes got 36 fps without changing anything (really, I mean absolutely nothing!). The Oculus debug tool overlay showed around a 5% performance overhead at 72 fps and -30% at 36 fps, and all I had to do to randomly flit between the two states was do Restart Session. Once in one of the two states, it would stay there however much driving you did.

    I don't know if this is a VR only issue or whether it might affect monitor users too, hence it not being in the VR discussion thread, but has anyone else seen anything like this, whether monitor or VR? The test was done running AMS2 in Oculus VR mode, so I don't know if the same traits would be apparent in Steam VR mode.

    As an aside, rF2 and AC always got 72 fps (both on quite high settings), and ACC always got 36 fps (on very low settings - it's a resource hog!). The one I liked the most was AC (good front end), and the one I liked the least was ACC (bad front end, which is odd how Kunos can make the same car handle so differently), with rF2 a close second to AC and AMS2 third (and before you ask, AMS2 was the bounciest, but still fun to drive). Lap time wise, rF2, ACC and AC were all around 1m28s, PC2 was 1m26.8s (but I used the 911 RSR as it didn't have a 911 Cup, and I'm not sure how similar they are), and AMS2 was the slowest at 1m31.4s.
     
    • Agree Agree x 1
  2. Ema76

    Ema76 New Member

    Joined:
    May 4, 2020
    Messages:
    6
    Likes Received:
    0
    Hi , I also have a frame rate problem in the race I have 60 fps very stable with the sun or cloudy and
    as soon as the sunset or nigth arrives it even drops to 40 fps ... I don't have this problem at all in PC2 :(
     
  3. Andrew Hollom

    Andrew Hollom Active Member

    Joined:
    Mar 9, 2019
    Messages:
    166
    Likes Received:
    60
    @Ema76 it's relatively normal behaviour in most sims, as the workload is higher at night, as is diffuse light (effectively many sources of light). Why PC2 behaves differently (and better) is odd.

    What I was trying to highlight is the apparent lottery of, I'm guessing, the game not allocating the least loaded core to process a thread, or using a virtual core when a real one is available, as these seem the most likely reasons why the performance differs randomly with no other changes (i.e. with constant graphical settings, weather, time of day, car and track). PC2 has the same fault, so I imagine it's a Madness engine characteristic/fault.
     
    • Agree Agree x 2
  4. Ema76

    Ema76 New Member

    Joined:
    May 4, 2020
    Messages:
    6
    Likes Received:
    0
    Yes ok , I understand what you are referring to , but in other sims I lose a maximum of 5/10 fps instead here the drop is stong :confuso:
     
  5. Chip

    Chip Active Member

    Joined:
    May 22, 2020
    Messages:
    112
    Likes Received:
    27
    I am having the exact same issue that you encountered with frame rates varying drastically without ANY settings being changed whatsoever between sessions. I'm using SteamVR, HP Reverb G2, and RTX 3080. Using Time Trial mode as my test, I booted up Hockenheimring and the Porsche GTE. Although I can get a session with a solid 90 FPS no matter how many laps in a row I run during the session, if I exit the session and then restart it without changing ANYTHING, I randomly can see performance drop down to 60-65 FPS.

    Does anyone know if there is a work-around or fix for this? I've tried to restart the game, and even my PC, multiple times in order to get back to the 90 FPS performance state whenever the lower performance is encountered, but it seems so random between the two. It's totally killing my AMS2 experience, and makes it unplayable. One time, I rebooted like a half a dozen times before I was able to get back to the 90 FPS state.
     
    • Like Like x 1
  6. BrunoB

    BrunoB King of Raceroom FR-US

    Joined:
    Jun 13, 2020
    Messages:
    1,279
    Likes Received:
    276
    Could it have something to do with difference in background processes?
     
  7. Chip

    Chip Active Member

    Joined:
    May 22, 2020
    Messages:
    112
    Likes Received:
    27
    Thanks for the response, I don’t see how it could be related to background processes since I’m not even exiting AMS2. However, I will check and post results.
     
  8. A.F.K DaN

    A.F.K DaN Member

    Joined:
    Oct 16, 2020
    Messages:
    39
    Likes Received:
    13
    Oculus has a feature called ASW (other brands have similiar features nowadays) which locks the applications frame to half the hz and sends every image 2x times to your HMD to make it less stuttery.

    By default this setting is not disabled, so you might start with 72 fps, but once your pc can't handle the load, your oculus will throttle output to 36 fps and double your images to mimic 72 fps. Sometimes, depending on games, if oculus sees you now have enough spare resource, it will unlock the frames again and you might get back up to 72 fps until the moment where your pc can't handle 72 fps once again.
    You can disable this behaviour for instance with the Oculus Debug Tool or OTT tool or with some keybind (think it was CTRL+Num1). In this case your game will produce always as many fps as it can handle, up to the maximum possible hz your HMD is running. But it will never double images if you drop lets say to 30 fps. So, it might be more stuttery after disabling, gotta test it for yourself.

    For me, I've disabled it on every app. I'm aiming to get a solid 80 fps on my Rift s on nearly every situation so thats what I tune my ingame settings to. If it drops to 65 to 70 fps for small moments, thats not a problem, but can't handle something like 30 fps. With ASW on, usuallly most games produce heavy shadowing, which I don't like at all, so always going for the full native FPS where possible.
     
    • Informative Informative x 1
  9. Chip

    Chip Active Member

    Joined:
    May 22, 2020
    Messages:
    112
    Likes Received:
    27
    Thank you for the reply. I wish it was as simple as disabling ASW, but ASW is not the issue. I disabled the equivalent of it long ago on my HP Reverb G2. The frame rates are clearly established at the beginning of the session. With my settings, 90 FPS should be consistent, and if I am lucky enough to get the session to start with 90 FPS, the frame rates will stay that way even an hour into hot lapping. However, if I start the exact same session with the exact same graphics settings the next day for instance, my FPS might be just above 60 FPS, and will stay that way throughout the session. I will try to capture a fpsVR screenshot, but like the OP stated in Post #3, this seems to be related to inefficient core/thread allocation based on what I've seen in fpsVR. If that's the case, I'm just hoping there is a way to consistently force the allocation to occur properly. The performance difference is drastic to say the least, and I should be more than capable of hitting 90 FPS with my setup...which is indeed the case when the core/thread allocation occurs efficiently.
     
  10. DavidGossett

    DavidGossett Active Member

    Joined:
    Mar 30, 2020
    Messages:
    147
    Likes Received:
    205
    I have noticed the frame rate seems less stable on TT than in normal races or practice. I'll practice or race with a track, have a stable 90fps, go to TT and suddenly it's constantly dropping to 45 and having Oculus "spacewarp" fill in the gaps.
     
  11. Chip

    Chip Active Member

    Joined:
    May 22, 2020
    Messages:
    112
    Likes Received:
    27
    Interesting. I will test that, but if that's true, then there would seemingly be an issue that needs fixing on Reiza's side.
     
  12. Chip

    Chip Active Member

    Joined:
    May 22, 2020
    Messages:
    112
    Likes Received:
    27
  13. Andrew Hollom

    Andrew Hollom Active Member

    Joined:
    Mar 9, 2019
    Messages:
    166
    Likes Received:
    60
    No, but I've not noticed it for a while, so perhaps something has been done. I remember it didn't seem to depend on graphical settings (i.e. lowering them didn't make a difference), I just had to so "restart session" till it was 72 fps (which you can't do in multiplayer!). I have 12 cores, so there should be a free one somewhere!
     
  14. Chip

    Chip Active Member

    Joined:
    May 22, 2020
    Messages:
    112
    Likes Received:
    27
    Thanks for the response. I concur: It's definitely NOT graphical settings. However, it still happens to me. When you restarted session, did you fully exit AMS2, or just the session itself and then hop back into the session? Just curious.
     
  15. Andrew Hollom

    Andrew Hollom Active Member

    Joined:
    Mar 9, 2019
    Messages:
    166
    Likes Received:
    60
    Just the session
     
  16. bazziboy

    bazziboy Member

    Joined:
    Jun 10, 2020
    Messages:
    40
    Likes Received:
    15
    To me this sounds very much like a Vsync issue. Since 36 is exactly the half of 72 fps.
    When your system cannot manage to render 72fps, it has to wait for the next frame then, which essentlially halves your framerate. Suggestion: Turn off Vsync, ingame or in the gfx-driver, OR if you have a freesync or anything comparable, turn that on.
     
  17. Andrew Hollom

    Andrew Hollom Active Member

    Joined:
    Mar 9, 2019
    Messages:
    166
    Likes Received:
    60
    It may not have been explicitly said, but this is a VR issue, which is why (for me at least) it revolved around the drop from full fps to half fps when ASW (a fancy frame interpolation that VR uses when it can't keep up) kicks in. Vsync isn't an issue in VR. Thanks for taking the time to comment though.
     
    • Informative Informative x 1
  18. bazziboy

    bazziboy Member

    Joined:
    Jun 10, 2020
    Messages:
    40
    Likes Received:
    15
    I see, unfortunately i have no experience with VR, although i'd like to try it with this game.
    Is there a possibility to switch ASW off, like VSync on monitors?
     
    Last edited: Aug 28, 2021
  19. Rob Davies

    Rob Davies Bobby Dazzler

    Joined:
    Jun 2, 2020
    Messages:
    88
    Likes Received:
    38
    Yes you can switch ASW off. For oculus devices I think it’s in the debug tool and for WMR you can do it in SteamVR settings.
     
  20. pavig

    pavig Member

    Joined:
    Aug 31, 2017
    Messages:
    32
    Likes Received:
    10
    Much as I love crewchief it seemed to be the cause of this problem at times on my system, as I started to notice that framerate drops happened immediately before he said something new. It was like the microstutters from paging new audio into memory was enough to throw out my frame pacing and cause a switch to half framerate mode. Switching off ASW caused an occasional dropped frame but no longterm interruption.

    It was hard to pin it down though because it didn't happen all the time, so some days no issue at all.
     

Share This Page