1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Auto rotation on Fanatec Wheels

Discussion in 'Automobilista - Help & Support' started by TrintaE2, Apr 14, 2017.

  1. Kevin Cox

    Kevin Cox Active Member

    Joined:
    Mar 11, 2016
    Messages:
    145
    Likes Received:
    32
    Still not working for me either. Will re get a fix anytime soon on this?
     
  2. Ernie

    Ernie Active Member

    Joined:
    Mar 8, 2016
    Messages:
    101
    Likes Received:
    36
    That's really strange. I have the same wheelbase with same driver and firmware. SEN is on AUT as well, and of course the Auto steering rotation in AMS is on. And all is working fine here.

    The only difference is, that i have just Win10 64bit Home and not the Pro version.
    As a side note: My windows user account is an administrator account. Maybe this makes a difference.

    Can you do the following check?:
    • Set the max rotation in Fanatec driver (900°)
    • Run AMS
    • Select (as an example) the Formula Retro and go on track
    • Quit AMS
    • Check the Fanatec driver again. It should show something like 450° or 540° (can't remember the exact value), but not 900° anymore.
     
  3. Kevin Cox

    Kevin Cox Active Member

    Joined:
    Mar 11, 2016
    Messages:
    145
    Likes Received:
    32
    Yes I have tried that with no luck. This does however work in rFactor 2. When leaving rFactor 2 my Fanatec driver always changes the rotation to the last car I drove.

    I am also logged into Windows 10 Pro as an admin.
     
    • Informative Informative x 1
  4. SirVanhan

    SirVanhan New Member

    Joined:
    Mar 10, 2016
    Messages:
    13
    Likes Received:
    0
    Steering Wheel Model: CSL Elite wheelbase with CSL Steering Wheel P1 for Xbox One
    Driver Version: 293 BETA
    Firmware Version: 336
    SEN setting: AUT
    Auto Steering Rotation (in game on controller screen): Yes and No, same thing with Aut
    Windows Version: Windows 10 Pro, 1709 Windows Fall Creators Update

    AUTO ROTATION NOT WORKING

    As I'm new to Fanatec, do you have an unbearable oscillation too?
     
  5. Sammy

    Sammy New Member

    Joined:
    Dec 4, 2017
    Messages:
    2
    Likes Received:
    0
    I've been reading, (but haven't tried yet), that oscillation can be caused by the DRI, (or Drift), setting in the CSL Elite wheel. Below is the section of the CLS Elite manual explaining this.

    6.3.6 DRI (Drift mode)
    DRI range: -05 ... -01 OFF 001 … 005 DRI default: -05
    The drift mode reduces overall resistance of the wheel and lets you turn the
    wheel more easily. It almost works like power steering. It reduces the basic
    dampening of the wheel in the range of -05 to -01 and makes the wheel turn
    faster in the range of 001 to 005. If the value is set to values beyond -05 (or if the
    games FFB interferes with this feature) you might experience


    Someone also posted a similar question about oscillation on RaceDepartment.com, see link below.

    PC - Fanatec csl elite oscillation problems

    Try this out and let us know how it goes. Cheers.
     
    Last edited: Dec 11, 2017
    • Friendly Friendly x 1
  6. SirVanhan

    SirVanhan New Member

    Joined:
    Mar 10, 2016
    Messages:
    13
    Likes Received:
    0
    Is the auto rotation and CSL Elite support being investigated for a future AMS bugfix (I don't know if there is going to be one) or do we have to wait for the future Reiza title?
     
    • Agree Agree x 1
    • Informative Informative x 1
  7. TrintaE2

    TrintaE2 New Member

    Joined:
    Jun 15, 2016
    Messages:
    26
    Likes Received:
    4
    Still nothing?!
     
  8. Kevin Cox

    Kevin Cox Active Member

    Joined:
    Mar 11, 2016
    Messages:
    145
    Likes Received:
    32
    Think the devs have given up on fixing this @TrintaE2 :(
     
  9. TrintaE2

    TrintaE2 New Member

    Joined:
    Jun 15, 2016
    Messages:
    26
    Likes Received:
    4
    Yeah, preety sure of that aswell. Apparentely there's a new firmware. I just noticed yesterday so maybe that makes a difference?! I'm sure fanatec has a role in this aswell...
     
  10. TrintaE2

    TrintaE2 New Member

    Joined:
    Jun 15, 2016
    Messages:
    26
    Likes Received:
    4
    Steering Wheel Model: CSL Elite wheelbase with 918 wheel
    Driver Version: 293 BETA
    Firmware Version: 336
    SEN setting: AUT
    Auto Steering Rotation (in game on controller screen): Yes and No, same thing with Aut
    Windows Version: Windows 10 Pro, 1709 Windows Fall Creators Update

    AUTO ROTATION NOT WORKING
     
  11. TrintaE2

    TrintaE2 New Member

    Joined:
    Jun 15, 2016
    Messages:
    26
    Likes Received:
    4
    Fixed??
     
  12. Sander Hogendoorn

    Sander Hogendoorn New Member

    Joined:
    Mar 8, 2016
    Messages:
    1
    Likes Received:
    0
    After quite a while I felt like installing AMS again after the last update, was trying for 2 hours to make the auto steering rotation to work (it always worked perfectly with my gt3rs v2!..).

    Now I gave up and found this thread, sort of glad its not just me, hope it gets fixed.
     
  13. TrintaE2

    TrintaE2 New Member

    Joined:
    Jun 15, 2016
    Messages:
    26
    Likes Received:
    4
    Yeah, been like this since build 1.4 or so...

    Reiza PLEASE!
     
  14. Gevatter

    Gevatter Active Member

    Joined:
    Mar 10, 2016
    Messages:
    108
    Likes Received:
    58
    Autorotation stopped working for me today as well on my Fanatec CSL Elite PS4. It broke when I opened controller.ini in documents\automobilista\user data to look for a way to apply some filtering to my FFB. Along the way I changed a few options, like turning off the LED stripe on my wheel base, small stuff. When I saved the file, it locked my wheel to 540° of rotation, as was specified in the controller.ini file under "user wheel rotation" (or something similar)

    It would lock my wheel rotation to whatever value I set there, no matter what options I set in the game menu afterwards. Even if I set a fixed rotation in the menu it would still stay at 540. Restarting the game and rebooting the wheel didn't help either. If I set SEN on the wheel from AUT to 108 and back to AUT, it stayed set to 1080°. The only thing that helped was deleting the controller.ini file and re-assigning my controls, now autorotation works again.

    I tested, and as soon as I open the controller.ini file and save it, it lock my wheel to (in my case) 540°. If I copy the file before editing and later recover it after the rotation setting have been broken, Autorotation works again.

    Sorry if I'm unclear, I'm quite tired. I'll clarify if necessary :)

    //edit: I'm more awake now, so I corrected errors and added details.
     
    Last edited: Jul 2, 2018
    • Informative Informative x 1
  15. Marc Collins

    Marc Collins Active Member

    Joined:
    Mar 12, 2016
    Messages:
    737
    Likes Received:
    219
    Auto rotation stopped working for me today, too! It broke when I updated the driver and firmware on my CSW. It appears that all cars are using the 900 (max) rotation from the Fanatec control panel. I tried turning Auto Steering Rotation ON and OFF; rebooting; deleting my controller.ini and forcing AMS to create a new one. Nothing fixes it, so it seems that the CSW has now joined the newer Fanatec wheels with this issue (based on what I read above).

    This is massively disappointing if it's a wheel issue. Auto Steering Rotation is one of my favourite features of AMS. However, it is understandable if people complained that a game (rF2 or AMS) was leaving their wheels in various rotation states. Apparently there was no way for AMS to read the rotation value from the wheel before loading so it could gracefully put it back to that value upon exit but still manipulate it while AMS was in use.

    If this is confirmed, I will see if there is way to go back to my old driver and firmware that had not caused me any issues.

    EDIT: Good news all around.

    1) I solved the problem by simply rearranging my controllers to ensure that the CSW was first in the list. I failed to mention that I had unplugged everything to do some unrelated work on my PC and had not put the USB cords back in the exact same places they came from. Auto Steering Rotation likely only works on the primary (first) controller as detected in AMS.

    2) The updated firmware and/or drivers from Fanatec now lock the wheel in place at your settings. The wheel control panel no longer adjusts to whatever rotation AMS is using. So, perfect. We get the auto rotation and tighter (more realistic) steering for most cars in AMS, but no other titles are screwed-up by AMS (or rF2) adjusting things for their own purposes and then not returning it to the (usually max) settings we asked for in the control panel.

    FURTHER EDIT: A bit of less good news.

    The bump stop at the end of the auto rotation that occurs before the end of the wheel's full rotation (900 degrees for my wheel) is gone. The wheel just goes flat (in terms of FFB) once you pass the AMS car's rotation limit.
     
    Last edited: Jul 7, 2018
    • Like Like x 1
  16. Marc Collins

    Marc Collins Active Member

    Joined:
    Mar 12, 2016
    Messages:
    737
    Likes Received:
    219
    @Renato Simioni thanks for liking my post above, but do you have a reply as to whether Fanatec versus Reiza should fix the loss of the soft bump stop?
     

Share This Page