1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Automobilista bug report thread (Please read the opening post)

Discussion in 'Automobilista - General Discussion' started by Renato Simioni, Aug 25, 2016.

  1. Wexodius

    Wexodius Member Reiza Backer

    Joined:
    Oct 16, 2016
    Messages:
    60
    Likes Received:
    16
    Track & Layout Used: does not matter (but I used Virginia this time around)
    Car Used: does not matter (but I used the ARC Camaro this time around)
    Applicable Settings: Be in pole position + have a rolling start
    Report: So when you are in pole position doing your formation lap the Safety Car is speeding along in front of you at around 100km/h. When the moment comes where the Safety Car re-enters the pit, so the rolling start can get going, a warning is mentioned in the text box that you may not accelerate too quickly (shows when you go above 100km/h -> doing so for too long will result in a drive-through penalty), you have to wait for the green flag to accelerate. Yet, I have had numerous times where the car in position number 2 will (before the green flag is waved!!!) starts to accelerate way above 100km/h and gets a considerate head start on you in the 1st lap of the race. This is unfair to the human player as you get penalized with the drive-through trying to catch up to him before the green flag is waved, the AI car does not get penalized accelerating way too soon.
    Steps to reproduce:
    1. Choose a race with rolling start
    2. Achieve pole position
    3. Do the formation-lap fully
    4. Notice how the Safety Car re-enters the pit
    5. Notice how there is no green flag waved yet
    6. Notice how the AI car on position number 2 starts to accelerate above the allowed speed and gain an unrightful head-start & does not get penalized with a drive-through as the human player will.
    7. Notice how the green flag is only now waved, signalling the cars it is okay to fully accelerate
     
    Last edited: Aug 1, 2017
  2. muzarati

    muzarati Member

    Joined:
    Mar 15, 2016
    Messages:
    54
    Likes Received:
    2
    Are the changes to the AI vehicle based in the HDV file, track based in the AIW file or PLR file? Point being, do third party mods and tracks need to be updated to these new standards?
     
  3. Angelo dos Santos

    Angelo dos Santos Member Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    34
    Likes Received:
    2
    Unfortunately, at the Jacarepaguá Oval, most of the AI´s (especially with more powerful cars) behave very badly. Crashing into the walls and going sideways with no purpose. Agressivity on Medium.
     
  4. Crux2237

    Crux2237 New Member

    Joined:
    Aug 2, 2017
    Messages:
    1
    Likes Received:
    0
    Track & Layout Used: N/A
    Car Used: Stock Car 2017, Full Time Bassani #44 Alberto Valerio
    Applicable Settings: N/A
    Report: Car isn't part of 2017 Stock Car class, unable to race him
    Steps to reproduce: Select the Stock Car series, choose the Stock Car 2017 opponent list, select a car different than the #44, set the AI opponents to 28 and try to race. Valerio won't be selected: instead, one of the other cars will be selected twice.

    I was able to fix it by editing the .veh archive, changing the class from "StockV8" to "StockV8_2017". That'll do it.
     
  5. yusupov

    yusupov Member Reiza Backer

    Joined:
    Jun 5, 2016
    Messages:
    76
    Likes Received:
    9
    got some weird stuff going on, but the crux of it seems to be something to do with my wheel (TM TX with 599 rim, stock pedals).

    i had to reinstall windows clean & i'm on a fast build (whatever the latest is) so that may be it; also only have the AMS beta installed.

    my user profiles are all over the place; they were on onedrive, moved to the documents folder have to the reinstall (had to create a new user), another new user created that ended up in a folder called "Windows 8" in AMS, & the latest is in the AMS root directory. this last one is the tracelog i included (from C:\Program Files (x86)\Steam\steamapps\common\AMSBeta\UserData\LOG).

    wheel seems to be fine & have done several file verifications. on a few occasions i've somehow dodged the problem & had no issues in that session.

    the issue is a CTD as soon as i leave the garage.
     

    Attached Files:

  6. muzarati

    muzarati Member

    Joined:
    Mar 15, 2016
    Messages:
    54
    Likes Received:
    2
    None of this is present in Reiza15.srs (SuperV8) I understand that the P2P shouldn't be there as it isn't relevant to the series. This might explain some of the issues?
     
    • Like Like x 1
  7. Alex Sawczuk

    Alex Sawczuk Well-Known Member Reiza Backer

    Joined:
    Feb 14, 2016
    Messages:
    1,022
    Likes Received:
    857
    There are hardcoded defaults, you don't need to edit them in anywhere generally.

    (although I will make sure those defaults are correct for the next build)
     
    • Like Like x 1
  8. muzarati

    muzarati Member

    Joined:
    Mar 15, 2016
    Messages:
    54
    Likes Received:
    2
    Well for me the AI in this build are terrible, they weave from side to side and all over the place, maybe like they are switching lines all the time or something? They don't stay on the racing line at all and crash into each other? Somethings not right, have validated files but no better.
     
  9. Alex Sawczuk

    Alex Sawczuk Well-Known Member Reiza Backer

    Joined:
    Feb 14, 2016
    Messages:
    1,022
    Likes Received:
    857
    I'm not saying you are wrong or anything, but put aggression down to low if you prefer how it was before for now.
     
  10. Omm

    Omm New Member Reiza Backer

    Joined:
    Aug 26, 2016
    Messages:
    16
    Likes Received:
    0
    AMS v1.4.5r

    Track & Layout Used: All
    Car Used: All
    Applicable Settings: Race
    Report: When the race is over and all cars return to the pits, a big stutter happen when every car disappears in front of their garages. (I don't have any stuttering during the race, thanks to delete d3d9.dll, and I play with spotter on, with hdd installation).
    Steps to reproduce: always when the cars return to their garages and disappears.
     
  11. Lorencini

    Lorencini Luciano Lorencini Reiza Backer

    Joined:
    Oct 10, 2016
    Messages:
    492
    Likes Received:
    305
    Will those AI parameters in SRS be used by car mods? I mean, if I put them in the mod SRS, will it be read by the game? This could be useful, as the modder could be able to fine tune AI in his car.
     
  12. Alex Sawczuk

    Alex Sawczuk Well-Known Member Reiza Backer

    Joined:
    Feb 14, 2016
    Messages:
    1,022
    Likes Received:
    857
    Yes, but the defaults should be sane and you shouldn't need to spend ages tweaking really.
     
    • Like Like x 1
  13. Edilson Freshi

    Edilson Freshi Member Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    52
    Likes Received:
    84
    Track & Layout Used: Doesn't matter
    Car Used: Stock car V8 2015
    Applicable Settings: Multiplayer mode
    Report: Push-To-Pass NOT WORKING on multiplayer mode.
    After second lap when you try to use P2P the game shows a message saying that you don't have push available anymore.
    AMS version 1.4.5
     
  14. Wexodius

    Wexodius Member Reiza Backer

    Joined:
    Oct 16, 2016
    Messages:
    60
    Likes Received:
    16
    Track & Layout Used:Montreal, Canada
    Car Used: ARC Camaro
    Applicable Settings: Race 30min
    Report: The game calculates 1 lap too many to finish the race. I was racing a 30min race in pole position. On the start of lap 16 I got told "white flag". It should have finished at the end of lap 16, cause I saw the timer was zero (0:00:00) before I shortly crossed the finish line on my "presumed" last lap. Yet, I had to do another lap (lap 17) before I saw the checkered flag and was confirmed that I won the race.
    Steps to reproduce:
    1. Choose a 30min race setting
    2. Choose ARC Camaro (although any car will do)
    3. Choose Montreal, Canada as track
    4. Race and be in the lead
    5. Notice "white flag" report on last lap
    6. Notice timer running out before finishing that lap
    7. Notice how you did not actually finish yet, you must do 1 more lap to see the checkered flag.
     
    Last edited: Aug 5, 2017
    • Agree Agree x 1
  15. muzarati

    muzarati Member

    Joined:
    Mar 15, 2016
    Messages:
    54
    Likes Received:
    2
    Created a new player profile to see if that helps and noticed that this entry "AI to AI Collision Rate="40" // Detection rate per second (1-40) for AI-to-AI collisions" is still the same default, there was some discussion that this must be updated to 80, is this the case? I did change it and am not 100% sure whether it made any improvement? I did notice it changed the way the AI left the starting grid in previous build, not for the better either.
     
  16. Lorincz Janos

    Lorincz Janos New Member Reiza Backer

    Joined:
    Jun 17, 2017
    Messages:
    15
    Likes Received:
    3
    AMS v1.4.5r
    Track & Layout Used
    : All
    Car Used: Stock Car 2015 and 2017
    Applicable Settings: Any
    Report: In TV cockpit view the rear window silhouette is always visible in the virtual mirror, regardless of the self view setting.
     
    Last edited: Aug 5, 2017
  17. Chris Stacey

    Chris Stacey Active Member Reiza Backer

    Joined:
    Jun 17, 2016
    Messages:
    113
    Likes Received:
    30
    AMS v1.4.5r
    Track & Layout Used
    : All
    Car Used: MetalMoro
    Applicable Settings: Multi Parc Ferme = 1
    Multi Free Settings = 13
    Report: Parc Ferme does not work anymore. Doesn't matter what you set the free settings to, they're all still able to be changed once you advance from qualifying to Race.

    Seems that in a lot of the Series files, Parc Ferme has simply been set to 0. Not sure if this is affecting it, but in the vast majority of cars, Parc Ferme does not work anymore.
     
    Last edited: Aug 6, 2017
  18. David

    David New Member Reiza Backer

    Joined:
    Mar 24, 2016
    Messages:
    2
    Likes Received:
    0
    AMS 1.4.5b, 1.4.5r
    Track & Layout Used:
    Doesn't matter
    Car Used: Doesn't matter
    Applicable Settings: Create Multiplayer server
    Report: When I create a server from the game (not a dedicated server), I choose a car class, Multiplayer, Create Game and then a vehicle, a track, the AI Drivers, AI Strength, AI Aggression, Race Time etc..., so when the server starts, everything is ignored, except of the car and the track. The number of AI Drivers is different, as well as AI Aggression, AI Strength, Race Time etc... When I create a dedicated server, everything is fine, but there is no choice for AI aggression.

    (Probably) help: If I want to set the AI aggression, I run the game, choose a class, Single Race, AI aggression. I'll finish the game, then launch the game, launch a dedicated server and then play.
     
  19. Heitor Facuri Cicoti

    Heitor Facuri Cicoti Good Member Staff Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    861
    Likes Received:
    820
    Track & Layout Used: Goiânia ST
    Car Used: Super Truck
    Applicable Settings: none
    Report: Game freezes during loading.
    upload_2017-8-7_16-10-30.png
    Steps to reproduce: Select Super Truck, Time Trial, Goiania ST and go.
     
  20. muzarati

    muzarati Member

    Joined:
    Mar 15, 2016
    Messages:
    54
    Likes Received:
    2
    Please confirm setting for this as 40 or 80?
    AI to AI Collision Rate="40" // Detection rate per second (1-40) for AI-to-AI collisions
     

Share This Page