1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bug Reports - Automobilista 2 (Read the Opening Post)

Discussion in 'Automobilista 2 - General Discussion' started by Heitor Facuri Cicoti, Apr 4, 2020.

  1. FrankyRed

    FrankyRed Youtuber

    Joined:
    Aug 28, 2020
    Messages:
    6
    Likes Received:
    2
    Might be a bug ???

    Camera mode tanks my PC giving me 9 FPS when I go into that mode.
    It's not even for a particularly tasking picture as the weather selected was sunny and only 12 cars on track.
    Replay works fine on the same scene in terms of fps but I'm also getting quite bad ghosting around the cars and scenery.
    Track was Guapore - Sunny - Online session.
    Cars were Omega Stock.
     
  2. Jeff Scharpf

    Jeff Scharpf Active Member

    Joined:
    Jan 25, 2020
    Messages:
    158
    Likes Received:
    91
    Version: 1.2.1.2
    Track and Layout Used: Donington
    Cars: BMW M1
    Bug: AI crews (one or two flag persons) are standing on the race track near the finish line. One flag person is entirely on the track, another appears to be partially glitched (halfway out of the wall into the track. Sorry I don't have pictures, but it is repeatable. AI crews were turned off.
    Steps to reproduce: Load up Donington and race I suppose.
     
  3. Jeff Scharpf

    Jeff Scharpf Active Member

    Joined:
    Jan 25, 2020
    Messages:
    158
    Likes Received:
    91
    Version: 1.2.1.2
    Track and Layout Used: Any track
    Cars: Any
    Bug: Required Pit Stops do not work.
    Steps to reproduce: Create a custom championship, set race distance to any laps, turn PIT STOP REQUIRED to ON. Save, then either start the championship or come back to edit, and the requirement will be turned off. Tried several full races and AI does not pit.
     
  4. F1Aussie

    F1Aussie Active Member

    Joined:
    Mar 21, 2016
    Messages:
    936
    Likes Received:
    235
    1. Version: 1.2.1.2
      Track and Layout Used: Brands hatch
      Cars: Ginetta GT4 Supercup
      Bug: First round of custom championship, real weather date of race 14/2/21, practice was rainy and foliage on trees was like from spring time, qualifying was dry with springtime foliage then the race was dry with winter foliage as would be expected.
     
  5. Nats

    Nats Member

    Joined:
    Jun 14, 2021
    Messages:
    34
    Likes Received:
    6
    Version: 1.2.1.2
    Track & Layout Used: Ibarra, Ecuador but happens in Campo Grande as well - may well happen in all tracks?
    Car Used: GT4 Camaro but happened with Stockcars as well - may happen with all other cars?
    Applicable Settings: Dry - but weather settings seem irrelevant
    Report: Car parts flash left and right really fast across the finish line opposite the pits once a car has retired to the pits - I think it happens in a straight line out from the pit bay where the car that has retired is sitting but not sure
    Steps to reproduce: Have a car retire from a race and then cross the finish line/straight opposite the pits where the retired car is situated
    Photo: Steam Community :: Screenshot :: Bug - flashing car parts across the finish straight whenever someone retires into the pits
     
    Last edited: Jul 6, 2021
  6. Nats

    Nats Member

    Joined:
    Jun 14, 2021
    Messages:
    34
    Likes Received:
    6
    Version: 1.2.1.2
    Track & Layout Used: Any
    Car Used: Any
    Applicable Settings: Dry but any
    Report: When you spin your car around with VSync On, certain track features judder in the distance, happen with any graphics settings
    Steps to reproduce: With Vsync On, drive at Ibarra Circuit, go to the far end of the course and head onto the grassed area, spin your car around on the grass. You will see the mountains judder whereas the open scenery over the lake does not. It's quite noticable. When I put off Vsync it doesnt happen or its not as noticable.

    It seems to happen worst on some sharp corners where you are turning very quickly.

    I think its vsync that is the issue here trying to render faster frames than my monitor can cope with and when vsync is on it slows the rendering of the background down to avoid tearing on my monitor which causes the juddering. It's more noticable since I got my new Ryzen 7 computer because I can play racing games at higher frate rates. I did notice it happening in some sharp corners in PCars2 as well a few years ago but I had a slower computer then so it was not so noticable. Seems worse in this game. When I turn vsync off it seems to stop the juddering but then I get screen tearing in the background graphics.

    Perhaps if the game had a way to limit frame rate that might help?

    Also mentioned on this Steam post by someone else: Stuttering camera movement :: Automobilista 2 General Discussions
     
    Last edited: Jul 10, 2021
  7. Maser V6

    Maser V6 Assume nothing. Verify everything. Have Fun Reiza Backer

    Joined:
    Mar 27, 2020
    Messages:
    1,546
    Likes Received:
    797
    Track & Layout Used:Cascavel
    Car Used: Fusca HC2 10 lap online human and AI
    Applicable Settings: Real weather 26/02/87
    Setting Compulsory pit stop damp track 93/93 ai setting
    Report
    : .All AI {but 2} miss pit entry then go back on track and get disqualified
    Steps to reproduce: Run pit stop race at specified track 20210704232926_1.jpg
     
    Last edited: Jul 5, 2021
  8. Luke Blum

    Luke Blum Member Reiza Backer

    Joined:
    Feb 21, 2021
    Messages:
    54
    Likes Received:
    38
    Hello reiza

    As an avid fan of the fclassic cars, since ive owned this game (for about 6-7 months now, give or take) I've noticed that the fclassic series has no fast damping settings. But, since 1.2, theyve had the option to change the number (without any actual adjustment happening) if you use the units setting. (as compared to the actual real rates setting, where it is still stuck at 0 nm/s. At the very least, its a dead slider on the units setting, if its like a WIP.

    Track & Layout Used: long beach (seems to happen in any track)
    Car Used: Formula classic gen 1-3
    Applicable Settings: units vs rates setting in main menu---> front and rear fast bump and rebound
    Report: can change the unit setting, but has no effect, and stuck at 0nms in rates setting
    Steps to reproduce: change the setting in the setup screen, when on units. drive, see if it changes behavior at all. then switch it to rates and see its stuck at 0nms (obviously if this is a work in progress, planning to be implemented later on, disregard)
     
  9. twistking

    twistking Member

    Joined:
    Apr 27, 2021
    Messages:
    48
    Likes Received:
    9
    MP: Desync AI "drifting" and levitating (pcars 2 issue)

    track & Layout Used
    : all
    Car Used: all
    Applicable Settings: Multiplayer fill with AI opponents
    Report: In multiplayer AI desyncs and AI appears to go sideways as if drifting, soemtimes AI levitates above the track. Visual damage repair does not get synced. Problem existed already in pcars2.
    Tested on different computers with different network/WAN setups
    Steps to reproduce: Open multiplayer with AI driver on dedicated server. If you host from game client, only other players will see the problem, as the hosting client itself is not affected.
    Problem is best seen in training/quali. I guess that is because the AI pitting and player JIP gives more possibilities for desync.
    Watch out for AI that levitate, AI that drive at an angle as if drifting and watch out for AI that have just pitted but are still visibly damaged.
     
    Last edited: Jul 5, 2021
  10. Haris1977

    Haris1977 Active Member

    Joined:
    Apr 7, 2020
    Messages:
    275
    Likes Received:
    63
    Version: 1.2.1.2
    Track and Layout Used: N/A
    Bug: In vehicle selection menu, cars do not have the same size
    Steps to reproduce: Go to vehicle selection menu and see the cars. E.g the below pic shows the GT4 class where the GT4 clubsport car looks small and the Camaro car (blue one) looks bigger. I know those cars may be of different lengths - but again the pic looks somehow awkward (maybe a zoom in for the small cars and a zoom out for the bigger ones?). The same happens for other classes too

    Untitled.png
     
  11. twistking

    twistking Member

    Joined:
    Apr 27, 2021
    Messages:
    48
    Likes Received:
    9
    MP: JIP players invisible

    *edit* not a bug, but still problematic
    I learned that the issue is indeed a feature to prevent active drivers from experiencing lags/stutter from JIP players init.

    I appreciate the thinking behind this feature, but i still think it's bad and should be improved. Maybe make it optional, so that players with ssd drives can choose to have instant init on other players JIP. Alternatively make it a serverside option. For small grids or single car / single class type of races init should not result in much stutter anyways...

    track & Layout Used: all
    Car Used: all
    Applicable Settings: Multiplayer training/quali JIP
    Report: In multiplayer players that join in progress are not visible for other player until those players press "return to pit box".
    Steps to reproduce: Open a multiplayer game.
    Have players JIP the session and drive out of the pit. Some players are not visible to other players. Returning to pit box fixes the problem.
     
    Last edited: Jul 6, 2021
  12. twistking

    twistking Member

    Joined:
    Apr 27, 2021
    Messages:
    48
    Likes Received:
    9
    MP: Visual damage desync (pcars 2 issue)

    track & Layout Used
    : all
    Car Used: all
    Applicable Settings: Multiplayer, damage full or damage visual only
    Report: In multiplayer visual damage states are not synced between players (includes headlights) and AI after reapair
    Steps to reproduce: Open multiplayer on dedicated server or self hosted
    Crash your car to get visual damage. Repair your car. Notice that other players will still see your car as damaged. Same with AI cars that will be visiblly damaged even after pit stop (it could be that hosting player does see AI damage correctly - not tested enough).
     
    • Informative Informative x 2
  13. InfernalVortex

    InfernalVortex Active Member

    Joined:
    May 10, 2020
    Messages:
    405
    Likes Received:
    226
    MP: Laps not counting

    track & Layout Used
    : Spielberg
    Car Used: Formula V10 G1
    Applicable Settings: Multiplayer
    Report: Game doesn't count a completed lap, leading a driver to improperly listed as a lap down. This is an issue when there are blue flags and penalties on, as that driver must yield to the pursuing cars and cannot pass them. It ruins their race. It makes hosting league races unappealing.
    Steps to reproduce: Seems random. But has happened twice now at Spielberg. Not sure how to reproduce.
     
  14. SoloWingX

    SoloWingX New Member

    Joined:
    Jul 3, 2016
    Messages:
    17
    Likes Received:
    3
    Track & Layout Used: Imola Modern
    Car Used: Formula Trainer Advanced (Any)
    Applicable Settings: Grass Quality - High
    Report: T17 (Rivazza 1) entry - Grass is growing where it shouldn't... on the astroturf. See screenshot.
    Steps to reproduce: My grass setting is at the highest. Haven't tested others.

    AMS2AVX_2021_07_05_17_09_20_095.png
     
  15. ramsay

    ramsay Member

    Joined:
    Jul 25, 2020
    Messages:
    69
    Likes Received:
    34
    Track & Layout Used: spa modern
    Car Used: gte bmw
    Applicable Settings: night racing damage off (visual only)
    Report: visual damage causes headlight damage
    Steps to reproduce: n/a
     
    • Agree Agree x 1
  16. ramsay

    ramsay Member

    Joined:
    Jul 25, 2020
    Messages:
    69
    Likes Received:
    34
    Track & Layout Used: n/a
    Car Used: n/a
    Applicable Settings: icm pitstop strategy editing
    Report: units set to imperial (psi) yet icm pitstop menu shows pressures as bar when it should be psi
    Steps to reproduce: open pitstop strategy
     
  17. ramsay

    ramsay Member

    Joined:
    Jul 25, 2020
    Messages:
    69
    Likes Received:
    34
    Track & Layout Used: n/a
    Car Used: n/a
    Applicable Settings: TT
    Report: when paused main screen at top shows mediums when softs are being used
    Steps to reproduce: TT
     
  18. rod1298

    rod1298 New Member

    Joined:
    Jul 6, 2021
    Messages:
    1
    Likes Received:
    0
    Track & Layout Used: Long Beach
    Car Used: Any
    Applicable Settings: Version 1.2.1.2
    Report: Track limits incorrect in turn 1 and pit exit resulting in penalty
     
    • Agree Agree x 3
  19. CrimsonEminence

    CrimsonEminence German localization/Testing Reiza Backer

    Joined:
    Nov 4, 2018
    Messages:
    4,379
    Likes Received:
    1,993
    You musn't drive over the pit exit line, it's also forbidden in real life.

    EDIT: wtf. this is actually broken now o_O
     
    Last edited: Jul 6, 2021
    • Agree Agree x 1
  20. Bizarre Formula

    Bizarre Formula Member

    Joined:
    Oct 11, 2020
    Messages:
    68
    Likes Received:
    27
    We were just in a session and I tried every line possible, couldn't get out of the pits at all without penalty. I spent a 20 minute session trying to find the 'safe' way out. =P
     
    • Agree Agree x 1

Share This Page