1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Potential FFB hickup, in need of some test data. Any volunteers?

Discussion in 'Automobilista - General Discussion' started by Niels Heusinkveld, Mar 4, 2017.

  1. Niels Heusinkveld

    Niels Heusinkveld Moderator Staff Member

    Joined:
    Feb 14, 2016
    Messages:
    20
    Likes Received:
    66
    Hey Guys,

    In short, I have been pulling my hairs out for years having seemingly random FFB and image stutters. The FFB can feel like there is sand in the steering rack and the graphics stutters are really visible. A few days ago I found the weirdest thing that seems to be the cause of my problem. I wonder if it may be happening to more people.

    When I delete the AMS intro video to save on loading times, my FFB is messed up.
    It is extremly ABSURD but it is 100% repeatable here. It makes no sense. I hope I am the only one but lets gather some data!

    Main settings
    There are a million settings but lets copy my settings to make sure we're doing the same thing:
    - Details full except shadows at medium
    - framerate cap at 120fps assuming your pc doesn't drop below this
    - VSYNC off
    - PURE FFB 360hz
    - Test day without AI

    Here's what I'd like you to do:
    - Get Fraps (you probably already have it) and enable "Frametimes" in the benchmark settings
    - Go in your MovieFiles folder and move the PreGame.bik somewhere else so the folder is empty
    - Do a test day, leave the pits, press F11 or the FRAPS benchmark hotkey you assigned
    - Do one steady outlap, press F11 to stop benchmarking

    Now quit AMS.
    Put the PreGame.BIK file back in the MovieFiles folder
    Start AMS Do the same benchmark again.

    Repeat the process 3 times to make (more) sure results are consistent and we don't get a one time glitch

    Interpreting the results
    In the FRAPS / Benchmark folder you have 6 CSV files, sort by date and if you followed procedure:
    - Oldest = without intro video
    - Next = with intro video
    - Next = without intro video
    - Next = with intro video
    - Next = without intro video
    - Newest = with intro video

    To not loose track, rename them to 'Without1' 'With1' 'Without2', 'With2' something like that so we know which is which after editing the files.

    - Start a spreadsheet program and open the first CSV file.
    - In cell C3 enter the formula = B3 - B2 to calculate the time between each frame
    - fill out this formula to the entire column
    - make a line chart from this collumn
    - name the chart 'with1' or 'without1' etc etc to know which we are looking at.
    - Set the Y scale maximum to 100 so each chart has the same scale up to 100ms frame time.

    My results
    I've attached a screengrab of my tests. You can see with the movie in place, I get a near perfect consistent 8.3ms frame time, indicating a smooth 120fps.

    Without the intro movie in place, there are a lot of stutters up to 90ms. The FFB feels really notchy and the stutters are clearly visible.

    Posting your results
    When you post your results, these may be interesting PC specs to mention:
    - Windows version
    - Graphics card?
    - FFB wheel type
    - Triple screen?
    - Multi view?

    I'm afraid this will take you half an our to do but I hope we can gather some data to see what happens here!

    Niels
     

    Attached Files:

  2. DaVeX

    DaVeX AMSUnofficial Staff Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    1,808
    Likes Received:
    928
    Sorry Niels, I am not at home so I can't do the tests, I hope to be able soon (weekend on parent's house) in order to help you, reading your post I have a question...you suffered stutter and weird ffb even before removing the .bik file?
    Because here on the forum there are a lot of posts about stutter going worse since spotter implementation and no way to remove it (stutter) until now...maybe is a problem related the way sim reads .bik, mp3 files? Because we have stutter every time spotter is calling advices or at the very beginning of the game while loading the intro, if the intro stutters even the car in the garage (while rotating) will suffer stutter and even ingame (but if I restart the sim and it loads the intro without stutter I don't have stutter anymore on garage but I have it ingame due to spotter), I have also noticed that if you do a defrag of the hdd where the sim is, you will have less stutter...so I had the feeling maybe can be a problem related the way the sim loads audio and video files...
     
    Last edited: Mar 4, 2017
  3. Niels Heusinkveld

    Niels Heusinkveld Moderator Staff Member

    Joined:
    Feb 14, 2016
    Messages:
    20
    Likes Received:
    66
    I've had stutters for years, but it could be 100% because of the video. Because I leave it in often, get annoyed after a month, delete it .. But then a month later I may do a new checkout or update and the file is back.. Personally I don't like the spotter so its one of the first things I turn off.

    It keeps saying 'No cars on the left' 'No cars anywhere' .. as I do moslty private testing! :D
     
  4. DaVeX

    DaVeX AMSUnofficial Staff Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    1,808
    Likes Received:
    928
    Can you try it too?Because I am sure the video and audio problems are related each other...
     
  5. Heitor Facuri Cicoti

    Heitor Facuri Cicoti Good Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    861
    Likes Received:
    831
    I'm willing to do it, but my details won't be set to full and FPS will be at 67. (Yep, there's not much a laptop can do) Will my data be usable? Otherwise I won't bother.

    Also,

    - Windows 10
    - AMD Radeon R9 M200X Series (from Samsung Ativ Book 6)
    - Logitech G27
    - No
    - No
     
  6. Empty Box

    Empty Box Active Member Reiza Backer

    Joined:
    Mar 17, 2016
    Messages:
    102
    Likes Received:
    99
    I don't have a spreadsheet program, but the benchmarks CSVs are attached.

    Posting your results

    When you post your results, these may be interesting PC specs to mention:
    - Windows version? Win 10 64
    - Graphics card? GTX 1070
    - FFB wheel type? Fanatec CSW v2
    - Triple screen? No
    - Multi view? No

    Also, vsync is disabled, but I do have a gsync monitor and that turned on. Shouldn't matter though if it's capped in game to 120?
     

    Attached Files:

    • Useful Useful x 1
  7. Heitor Facuri Cicoti

    Heitor Facuri Cicoti Good Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    861
    Likes Received:
    831
    I had nothing to do and, being unable to drive right now, I took the liberty to plot EB's data:
     

    Attached Files:

    • Useful Useful x 1
  8. Niels Heusinkveld

    Niels Heusinkveld Moderator Staff Member

    Joined:
    Feb 14, 2016
    Messages:
    20
    Likes Received:
    66
    Thanks Matt, Heitor.

    Sofar only I seem to be affected by this impossinly weird issue of a missing intro video causing FFB and framerate stutters..

    Matt, you do have some stuttering going on with some frames takin 30ms instead of 8ms to draw. If you're not really noticing them that is fine but if you get annoyed by them, seems something is not quite allowing the sim to run super smoothly..
     
  9. Scraper

    Scraper Well-Known Member Reiza Backer

    Joined:
    Aug 9, 2016
    Messages:
    1,087
    Likes Received:
    787
    That is a weird problem. Why on earth would a movie file deletion cause FFB and framerate stuttering? Perhaps it's something more global than local if it affects two issues at the same time. I presume you have ruled out the following?
    • Malware issues.
    • Anti-virus software not running on silent mode.
    • Hard drive needs defragging.
    • All device and graphics drivers up to date.
    • PC power option to High Performance.
    What happens to AMS when it looks for the movie file and doesn't find it? Although it obviously continues with the game, perhaps there is a memory leak of some sort? Perhaps AMS continues to search for the file while coping with FFB and FPS.

    Maybe something like Project Lasso could help you track what processes are occurring/memory use when the game is running? Too many questions. Sorry!
     
    Last edited: Mar 6, 2017
  10. Big_Mama

    Big_Mama Ben Suttor Reiza Backer

    Joined:
    Nov 2, 2016
    Messages:
    179
    Likes Received:
    129
    Hi Niels,

    an other info people could provide, or you could consider, is the type of sound card that is in use. Actually my main OS is a Linux distribution and ever since I switched to an external sound card I had lots of problems with several games, especially in ported games that use some kind of wrapper, or when using the wine emulator. I never really understood why it happens. It could be the cause of a wrong setting, bad driver, a usb issue, too high cpu load etc...

    Now, those problems might not be related to your's, but don't forget to consider your sound device. My problem resulted in sound issues and frame drops(!) simultaneously
     
    • Like Like x 1
  11. DaVeX

    DaVeX AMSUnofficial Staff Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    1,808
    Likes Received:
    928
    In general we have stutter if the intro suffer of stutter too even the car in the garage (while rotating) will suffer stutter too and even ingame. If I restart the sim and it loads the intro without stutter I don't have stutter anymore...
    So you aren't the only one suffering stutter due to intro video...
     
  12. Heitor Facuri Cicoti

    Heitor Facuri Cicoti Good Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    861
    Likes Received:
    831
    So far he is the only one. His cause is the missing intro file. If you have stutters during the intro, it's obviously not because of missing intro file.
     
  13. Heitor Facuri Cicoti

    Heitor Facuri Cicoti Good Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    861
    Likes Received:
    831
    Assuming he had the same run every time, there are two spikes at the start of the test that seems to be regular. Maybe track related, maybe spotter...
     
  14. Scraper

    Scraper Well-Known Member Reiza Backer

    Joined:
    Aug 9, 2016
    Messages:
    1,087
    Likes Received:
    787
    I've just had some bad stuttering for the first time this year. Project Lasso was running, so I had a look at its processes list. The stuttering seemed to coincide with microsoftphotos.exe. A quick Google revealed that it is a background task that is known as a CPU hog, sometimes taking as much as 30-40% of the CPU - could this be a cause of both the FFB and framerate problems? The file is the Windows Photo app but it's a strange one - people say that it does not have a valid security signature. Re-registering the app can help.

    I wouldn't have mentioned this (I'm no expert, and I don't want to send Niels on a wild goose chase) but the app can be assigned to deal with video files as well as photos. If this post isn't useful, I will delete it so it won't be a distraction.
     
  15. Heitor Facuri Cicoti

    Heitor Facuri Cicoti Good Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    861
    Likes Received:
    831
    What about the big screens around the circuit? Could they be trying to access the intro file and that be the cause?

    And, if I'm not mistaken, there's a PLR entry to disable those big screens. Supposing Matt has it disabled, that would explain why Niels have the issue and Matt doesn't.
     
    • Creative Creative x 3
  16. DaVeX

    DaVeX AMSUnofficial Staff Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    1,808
    Likes Received:
    928
    After a quick test I can confirm stutter is more frequent and heavy near the big screens...:eek:
     
    • Agree Agree x 1
  17. Alex Sawczuk

    Alex Sawczuk Well-Known Member Reiza Backer

    Joined:
    Feb 14, 2016
    Messages:
    1,022
    Likes Received:
    857
    Big screens have a separate file, but if that's a confirmed issue we can make it possible to disable them
     
  18. Alex Sawczuk

    Alex Sawczuk Well-Known Member Reiza Backer

    Joined:
    Feb 14, 2016
    Messages:
    1,022
    Likes Received:
    857
    You can disable them already (movies on track), search for 'play movies' in your PLR file. We'll add it as an option to the UI soon.
     
    • Useful Useful x 2
    • Like Like x 1
  19. DaVeX

    DaVeX AMSUnofficial Staff Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    1,808
    Likes Received:
    928
    Seems I am the only one...
    ...hope will help!
     
  20. Tr51

    Tr51 Member Reiza Backer

    Joined:
    Mar 10, 2016
    Messages:
    51
    Likes Received:
    9
    No !! unfortunately it did not work out (in my case)
    I tried all possible options ... but random stuttering persists again.

    It is really unnerving
     

Share This Page