1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Steering wheel rotation range

Discussion in 'Automobilista 2 - Help & Support' started by racer7, Apr 2, 2020.

  1. racer7

    racer7 New Member

    Joined:
    Mar 3, 2020
    Messages:
    6
    Likes Received:
    4
    I followed Cheekymonkeys directions and it worked for me. I would still prefer a manual override like rf2.
     
    • Like Like x 2
  2. Jugulador

    Jugulador Active Member

    Joined:
    Apr 1, 2020
    Messages:
    132
    Likes Received:
    91
    Still not working with this update, even after delete my settings folder as instructed.
     
  3. KCW

    KCW Member

    Joined:
    Apr 10, 2020
    Messages:
    42
    Likes Received:
    6
    Try this:

    • Set to 540°
    • Load up game and go to calibrate wheel
    • Turn the wheel upside down (180°)
    • Click next
    • Turn the wheel to 90°
    • Click save
    • Drive cars and test.

    I know that is not going to be correct steering ratios on SOME cars, but a lot it will, and either way it should match up on screen for every car.

    That is just a test, does not mean you have to leave it that way, you set DOR any way you like.

    Ultimately the way you calibrate the wheel in game decides the DOR, you can essentially set it any way you like and the on screen wheel will automatically match your movement if you do it correctly.
     
    • Like Like x 1
  4. Jugulador

    Jugulador Active Member

    Joined:
    Apr 1, 2020
    Messages:
    132
    Likes Received:
    91
    Partially solved!

    On Logitech driver, I created a profile for AMS2 and now the game kinda adjusts the rotation range.

    All cars but karts work synchronized (real wheel and ingame). But all cars are locked at 450º or rotation, even those that are 900º, but now they work synchronized (and this 450º limitation is not bad). So, now the game limited all cars to 450º, but karts (that use 280º) are too loose to drive.
     
  5. Maro_Marinov

    Maro_Marinov New Member

    Joined:
    Apr 22, 2020
    Messages:
    4
    Likes Received:
    3
    Since version 1.0 I also have this problem - all cars have a wheel rotation of 900 degrees as my wheel (Logitech G27).
    It was fine before 1.0, the sim was setting the correct rotation for each car.
    Tried to rest settings to default, deleted the folder in MyDocuments, nothing helps. :(
     
  6. Jugulador

    Jugulador Active Member

    Joined:
    Apr 1, 2020
    Messages:
    132
    Likes Received:
    91
    I solved my DFGT isue when quit using the Logitech driver and begin to use only the Windows 10 generic driver.

    But there is a bug now, that every time, before use the DFGT I need to enter and exit (without change anything in) the last configuration screen on this driver settings. If I don't it will be stuck at 200º and de-sync in-game... otherwise it works as it should.
     
  7. Peter Eckhardt

    Peter Eckhardt New Member

    Joined:
    Mar 9, 2016
    Messages:
    10
    Likes Received:
    1
    Set my game to 900 but didnot work for me .Adjust 450 on my CSW2.5
     
  8. Mauro Handro Paz

    Mauro Handro Paz New Member Reiza Backer

    Joined:
    Sep 11, 2016
    Messages:
    11
    Likes Received:
    1
    From the past 20 years I have been using 270º of wheel rotation on all my sims, including AMS1, so I am used to drive with little wheel inputs. However, AMS2 is ignoring my G27 Logitech Profiler setting of 270º of rotation and applying different rotations according to each specific car. This is making the cars impossible to drive for me, even after adjusting car`s steering lock to the maximum. Does any one know how to manually adjust the wheel rotation or prevent the game from doing what it is doing ? Thanks !
     
  9. Jugulador

    Jugulador Active Member

    Joined:
    Apr 1, 2020
    Messages:
    132
    Likes Received:
    91
    Try not use the Logitech's driver, only the Windows 10's, that have almost the same setting options, included the steering rotation and the checkbox "let the game configure automatically". Maybe you set 270º with no game interfering there and it will work.
     
  10. Mauro Handro Paz

    Mauro Handro Paz New Member Reiza Backer

    Joined:
    Sep 11, 2016
    Messages:
    11
    Likes Received:
    1
    Thanks for your reply Jugulador. I have uninstalled Logitech`s Profiler from my Windows 10, however I am not being able to find where on Windows 10 those wheel settings are. I have found the wheel on the devices list, but the only option when I click on it is to remove it. Could you please give me a hint ? Thanks !
     
  11. Jugulador

    Jugulador Active Member

    Joined:
    Apr 1, 2020
    Messages:
    132
    Likes Received:
    91
    All my life I used the PT-BR version of Windows, and because of it I can't accurate state the English names, but I'll write both:

    Configurações do Windows > Dispositivos > Dispositivos e Impressoras (um link ao lado direito da tela) > clique com o botão direito no icone de seu volante depois que ele estiver conectado e "ligado" e escolha a opção Configurações do Controlador de jogo > Propriedades > finalmente escolha a opção Configurações, que é o painel parecido com o do driver da Logitech

    Windows Configurations > Devices > Devices & Printers (at a right screen side link) > right mouse click on your wheel icon after it's connected and "turned on", them choose the option Game Control Configuration > Proprieties > finally choose the option Configurations, that is like the Logitech driver control panel.

    I still have my DFGT driver installed, but I don't initialize it with the Windows. Just initialize it to use it's custom configs for Assetto Corsa to make a tweak to change gears both on DFGT sequential and rear buttons (the game recognizes only one input for each command).

    PS: I made a desktop shortcut to the DFGT icon, so I can change it whatever I wish (and fix the wheel glitch I stated early in this tread) without going all this way every time.

    Cheers!
     
  12. Mauro Handro Paz

    Mauro Handro Paz New Member Reiza Backer

    Joined:
    Sep 11, 2016
    Messages:
    11
    Likes Received:
    1
    Thanks for the tips ! Found it, but there is no option to set rotation nor the check box you mentioned, just a axis / buttons test screen, and another screen to calibrate the wheel. Tested AMS 2 without the driver installed and now the wheel is stuck on 180º of rotation, regardless of the car. This is less than I was used to, but i it is better this way than before. If the absence of the driver affects other sims I will try to do what you have mentioned. Thanks again !
     
  13. Jugulador

    Jugulador Active Member

    Joined:
    Apr 1, 2020
    Messages:
    132
    Likes Received:
    91
    Try to reinstal your driver, but don't let it initialize with the Windows and don't open it again. Maybe this screen of mine appears like this just because I didn't uninstall it.
     

    Attached Files:

  14. Mauro Handro Paz

    Mauro Handro Paz New Member Reiza Backer

    Joined:
    Sep 11, 2016
    Messages:
    11
    Likes Received:
    1
    Followed your suggestions and the options of the profiler appeared as you guessed. However, by reinstalling the driver, even preventing it from loading, the issue of AMS2 ignoring the adjusted driver wheel rotation came back. Then one friend of mine provided me a hint on how to make the wheel sensitivity setting to work. I messed with it and noticed that increasing this setting the steering rate increases, so the root issue (low steering rate) I had was solved, despite having a much greater wheel rotation. Thanks for the suggestions anyway !
     
  15. Skaegbiffet

    Skaegbiffet New Member

    Joined:
    Jun 22, 2020
    Messages:
    3
    Likes Received:
    3
    I had this issue too on my CSW. I had the range for the wheel set on the wheelbase to 900 instead of auto. If it isn't set to auto it will not adapt the range of the car you're driving.
     
  16. BrunoB

    BrunoB Active Member

    Joined:
    Jun 13, 2020
    Messages:
    958
    Likes Received:
    206
    Hey guys - this will not fix your problem with the missing correlation between your physical wheel and the AMS2 virtual wheel.
    But I have allways (mostly) been driving with the virtual wheel enabled - and after reading this thread I have suddenly realised that the virtual wheel is turning more/faster than my physical one.
    But as I have got accustomed to focussing on the virtual one it absolutely doesnt matter (for me ;)).
    Furthermore I have adjusted the AMS2 virtual wheel to have a progressive law turning slower in the mid but faster in the sides - but even this extra missing correlation doesnt matter (for moi :p).
     

Share This Page