1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stuttering caused by Nvidia PhysX

Discussion in 'Automobilista - Help & Support' started by Darryn Hatfield, Jan 20, 2017.

  1. Darryn Hatfield

    Darryn Hatfield New Member Reiza Backer

    Joined:
    Sep 9, 2016
    Messages:
    18
    Likes Received:
    6
    Hi,

    I have been having a hell of a time lately trying to get AMS working without stuttering. All of my testing has been done in single player gameplay and doing non-private test sessions with various cars and tracks.
    I have gotten to the point that I have rebuilt my PC and uninstalled and reinstalled (from backup) AMS. The only non default settings I have are turning virtual mirrors on.
    My stuttering issues seem to happen when one of 3 things happen.....I am leaving the pits......I am passed by another car (if we are close) and thirdly, if I have a big accident or spin or seem out of control somewhat....
    I have uninstalled the whole NVIDIA driver package (HD Audio, 3d Vision, Geforce Experience and PhysX software) except the NVIDIA driver itself without success. I now went into the control panel and found in the Confiure Surround, PhysX settings that the PhysX settings were set to auto select. I have changed it to CPU and it seems to have resolved the issue (fingers crossed).

    Has anyone had this issue or does this not sound correct? It's early days yet since my change so I am hoping that it is the resolution and if so what do I need to do to get this added to the administrators, sticky thread so that it can help others?
     
  2. Darryn Hatfield

    Darryn Hatfield New Member Reiza Backer

    Joined:
    Sep 9, 2016
    Messages:
    18
    Likes Received:
    6
    Hi Guys,

    More testing and it hasn't resolved it completely but it seems to have improved. Anybody else have this then please let me know. NOTE: I have already set Maximum Pre-Rendered frames to 1 the manual suggested.
     
  3. Rodders

    Rodders Active Member Reiza Backer

    Joined:
    Jul 25, 2016
    Messages:
    244
    Likes Received:
    54
  4. Javi288

    Javi288 Member Reiza Backer

    Joined:
    Apr 18, 2016
    Messages:
    50
    Likes Received:
    24
  5. RWB Charger

    RWB Charger Active Member Reiza Backer

    Joined:
    Dec 1, 2016
    Messages:
    113
    Likes Received:
    47
    Do you use windowed mode?
     
  6. Darryn Hatfield

    Darryn Hatfield New Member Reiza Backer

    Joined:
    Sep 9, 2016
    Messages:
    18
    Likes Received:
    6
    Hi Guys, Thanks for the responses.

    To answer your questions, yes I have the the sticky thread on stuttering but haven't had success with the points they raised.....I do have triple screens but am playing in single screen mode (other screens as disabled during gameplay). Lastly, I am playing in full screen mode.
     
  7. Professionalsimracing.com

    Professionalsimracing.com Active Member Reiza Backer

    Joined:
    Mar 12, 2016
    Messages:
    377
    Likes Received:
    132
    What about time acceleration?
     
  8. Darryn Hatfield

    Darryn Hatfield New Member Reiza Backer

    Joined:
    Sep 9, 2016
    Messages:
    18
    Likes Received:
    6
    time acceleration works fine
     
  9. Professionalsimracing.com

    Professionalsimracing.com Active Member Reiza Backer

    Joined:
    Mar 12, 2016
    Messages:
    377
    Likes Received:
    132
    Sorry I meant there used to be a suggestion to not use accelerated time progression if getting stuttering.
     
  10. Darryn Hatfield

    Darryn Hatfield New Member Reiza Backer

    Joined:
    Sep 9, 2016
    Messages:
    18
    Likes Received:
    6
    Ahh OK.. You mean Time Scale....I originally had it set to Normal but now I have it set to Off (I missed that one....I thought Off was Normal). I now have the following setup:
    Display settings on Basic
    Shadows are Off
    Shadow Blur is Off
    DynHUD is Native
    Virtual Mirrors are Off
    Maximum Pre-Rendered frames to 1 in Nvidia Control Panel
    Full Screen Mode
    Vsync
    SweetFX disabled
    NVidia PhysX Set to CPU
    All tests performed in Test Day Non-Private (Local Player, not multiplayer)
    I am still getting stutters. No as bad as I used to get them but still bad enough to disrupt play. Any other ideas?
     
    Last edited: Jan 21, 2017
  11. Professionalsimracing.com

    Professionalsimracing.com Active Member Reiza Backer

    Joined:
    Mar 12, 2016
    Messages:
    377
    Likes Received:
    132
    What FPS r u getting? R u capping it?

    Sry nvm I see vsync now. Try capping FPS instead.
     
  12. Darryn Hatfield

    Darryn Hatfield New Member Reiza Backer

    Joined:
    Sep 9, 2016
    Messages:
    18
    Likes Received:
    6
    I capped it at 60 in the game as well now....
    I just had a quick 5 min run and it did give me one small glitch (not enough to cause an issue in gameplay).
    I think I am getting close to optimal now but I need to give it a good test.....Thanks for the advice. I will try later today and let you know how I go.
     
  13. Scraper

    Scraper Well-Known Member Reiza Backer

    Joined:
    Aug 9, 2016
    Messages:
    569
    Likes Received:
    313
    The manual recommends in-game capping at 1.5 x the desired framerate. Try capping AMS at 90 FPS in the settings menu.

    Have you used adaptive VSync? It allows the framerate to dip below the chosen level when your PC/GPU struggles to keep up, giving a much smoother experience.
     
  14. Darryn Hatfield

    Darryn Hatfield New Member Reiza Backer

    Joined:
    Sep 9, 2016
    Messages:
    18
    Likes Received:
    6
    how do you setup adaptive vsync?
     
  15. Scraper

    Scraper Well-Known Member Reiza Backer

    Joined:
    Aug 9, 2016
    Messages:
    569
    Likes Received:
    313
    1. Open Nvidia Profile Inspector.
    2. Select the Automobilista profile (or create one).
    3. In the Sync and Refresh section, find Vertical Sync Tear Control.
    4. Select Adaptive.
    5. Save your changes.
    From the manual:

    "Additionally running in VSync (Only works in fullscreen mode) or setting the FPS limit in the Display Settings to around 1.5x your refresh rate may also help reduce stuttering."

    I hope this helps you.
     
  16. Professionalsimracing.com

    Professionalsimracing.com Active Member Reiza Backer

    Joined:
    Mar 12, 2016
    Messages:
    377
    Likes Received:
    132
    I'd recommend removing vsync and use cap only and at as high a rate as possible. For example, I could never get vsync to be smooth and also I need at least 110 FPS cap to be smooth.
     
  17. Darryn Hatfield

    Darryn Hatfield New Member Reiza Backer

    Joined:
    Sep 9, 2016
    Messages:
    18
    Likes Received:
    6
    Well I installed MSI Afterburner to check if anything was happening on my PC during these stutters and nothing except framerate drops.......
    I change frame rate cap to 1.5 times VSYNC and it didn't help any....
    I disabled vsync and that didn't improve.
    I even uninstalled the nvidia driver and went with the windows default which is 21.21.13.7595 (I was on 21.21.13.7633). I also set the pre-rendered frames to 1 as recommended on the new driver.
    To be honest the issues are so random for me that I just can't tell any more what works or not.
    I can say based on my last few laps that the major stutters have been getting passed by AI cars. It is not driveable now....

    All of my other settings have been as described.

    Is there a way of logging a support ticket that may be a better way to go....? I have other RaceSim games to play but in all honesty, this is my favourite by a mile so I really want this to work.
     
  18. Professionalsimracing.com

    Professionalsimracing.com Active Member Reiza Backer

    Joined:
    Mar 12, 2016
    Messages:
    377
    Likes Received:
    132
    Have you tried fewer AI? Just for curiosity.
     
  19. Darryn Hatfield

    Darryn Hatfield New Member Reiza Backer

    Joined:
    Sep 9, 2016
    Messages:
    18
    Likes Received:
    6
    yeah but i don't think that is the issue. i'm wondering if the stutters from ai drivers passing is a different issue to other stutters. i just need to get more testing info from reiza as I'm not convinced that I'm testing this correctly
     
  20. 2ndLastJedi

    2ndLastJedi Well-Known Member Reiza Backer

    Joined:
    Sep 7, 2016
    Messages:
    1,834
    Likes Received:
    635
    I find v-sync in nVidia control panel best . Depending on GPU power maybe your getting a constant fps but your frametime jumps around a bit .
    V-sync will exaggerate stutter massively . I cant get the game to look or feel smooth without v_sync so having it off is never a option for me .
    I have only just seen your thread and not sure you have given PC specs? What Ram ,HDD and CPU/GPU ? Give more details !
    Should Not Physx be set to Auto or GPU?
     

Share This Page