1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stuttering issues - discussion & suggestions

Discussion in 'Automobilista - Help & Support' started by Spin, Oct 9, 2016.

  1. Spin

    Spin Member

    Joined:
    Apr 15, 2016
    Messages:
    197
    Likes Received:
    23
    Have a quite serious issue going on with AM. This issue stems back to Stock Car Extreme (and possibly 2013 or even before) but I used to only notice it on karting tracks but now I notice it much more places. And it's making the game unplayable.

    Track & Layout Used:
    Many tracks (most recently used Floripa)
    Car Used: Any car - (most recently used BV8 and FVee)
    Applicable Settings: Having "Time Scale" and "Shadows" simultaneously set to anything other than "none" and "off" respectively
    Report: A constant, perfectly timed interval stutter exactly 1 second or so apart. I believe it has to do with the sun/shadows/night/day refresh/update stuff.
    Steps to reproduce: If you take a car out on Floripa, you can see this quite easily. The easiest way to see it is to drive the car from TV cam view (enable steering help full, TC, ABS, SC, etc.) and look at the big stutters / frame-skips that happen especially when the car is driving past the cam in a side view or 3/4 view. It's easily noticeable when driving too.

    Two ways to avoid this problem:
    A) Set "Time Scale" to "none" (not "1x", or "2x", or anything other than "none"). Doing so allows for "Shadows" to be set to any setting, even "Full", with no problems.

    B) Set "Shadows" to "off" (not even "minimum" but "off"). Doing so allows for "Time Scale" to be set to any setting with no problems.

    So you have to either fully disable day/night cycles or shadows; you can't run both at the same time as there are issues when doing this.
     
    Last edited: Oct 13, 2016
    • Agree Agree x 1
    • Informative Informative x 1
  2. roby13

    roby13 Active Member

    Joined:
    Mar 8, 2016
    Messages:
    185
    Likes Received:
    46
    Shadow Updates="8" // Static shadow updates per frame (Shadow Updates * Sky Update Frames should exceed number of static shadows on track)
    Sky Update Frames="200" // Frames between sky and light updates

    try set the fps limit to a prime number. some say it works (its not called the stig)
     
    Last edited: Jul 5, 2017
    • Funny Funny x 1
  3. Spin

    Spin Member

    Joined:
    Apr 15, 2016
    Messages:
    197
    Likes Received:
    23
    Thanks for the reply. I'm not sure what you mean by "primary" number? I've tried 138 fps to 144 fps using the in-game fps limiter. Are any of those "primary"? I also tried 120 fps / 120 Hz. I can't remember if I saw the issue at 60 fps (120 fps total - 60 fps / eye) during Nvidia 3D Vision mode but it occurs in at-least all 2D modes.

    Do you know what difference changing the shadow updates to 8 and sky update frames to 200 make? Do the updates happen less frequently, or does it affect the amount of shadows rendered (regardless of in-game shadow setting) or something??
     
    Last edited: Oct 12, 2016
  4. roby13

    roby13 Active Member

    Joined:
    Mar 8, 2016
    Messages:
    185
    Likes Received:
    46
    Afaik: shadow updates per frame controll the shadow transitions. The smaller the number the less smooth shadows move with light angle change. Second value is similar. The smaller the number the more often sky and light get updated. For prime mumbers just google. An example sequence: 109, 113, 127, 131, 137, 139, 149, 151 please share your results if u get anywhere
     
    Last edited: Jul 5, 2017
  5. Spin

    Spin Member

    Joined:
    Apr 15, 2016
    Messages:
    197
    Likes Received:
    23
    OK. Just finished a bunch of testing:

    Setting fps limit to a prime number

    137 - no difference
    139 - no difference

    Changing Shadow Updates - Default: 8
    2 - no difference
    32 - no difference

    Changing Sky Update Frames - Default: 150
    200 - changes the constant time interval to a longer one so the glitch/bug happens, let's say, every 1.25 seconds instead of every 1 second
    50 - changes the constant time interval to a shorter one so the glitch/bug happens, let's say, every 0.2 seconds instead of every 1 second


    My conclusion is that the game engine "glitches" and can't handle certain camera angles / tracks / corners depending on some variable/s (amount of real and/or static shadows?? No idea). The fact this happens at some corners and camera angles but not others leads me to believe the game-engine has issues when it doesn't like some combination of variables.

    Despite information in multiple forums across the web, "Sky Update Frames" does not fix the issue, it only adjusts the timing of the issue.

    - link to bug/glitch explanation for reference: Automobilista V1.0 bug report thread (Please read the opening post)
     
    Last edited: Aug 24, 2017
  6. Alex Sawczuk

    Alex Sawczuk Well-Known Member

    Joined:
    Feb 14, 2016
    Messages:
    1,029
    Likes Received:
    858
    Just at Floripa or lots of tracks?
     
  7. Spin

    Spin Member

    Joined:
    Apr 15, 2016
    Messages:
    197
    Likes Received:
    23
    I'll do tests later tonight when I'm off work for you guys.

    I think it depends on camera angle, not just corner, so I'll test all tracks and layouts using all sets of TV cams (set 1, 2, 3, etc.) and the cockpit view. I'll give a full report sometime in the next 24 hrs
     
  8. Alex Sawczuk

    Alex Sawczuk Well-Known Member

    Joined:
    Feb 14, 2016
    Messages:
    1,029
    Likes Received:
    858
    Some stuttering from TV cams, especially with lots of cars is kinda known mind
     
  9. Spin

    Spin Member

    Joined:
    Apr 15, 2016
    Messages:
    197
    Likes Received:
    23
    The stutters I'm reporting are all when also playing with 1 car only, furthermore, they also occur when not in TV cam it's just that TV cam makes them easier to notice because you can look at the background scenery which makes it easier.

    Points to consider
    • The stutter happens regardless of the amount of cars on track (1 car, 15 cars, etc.)
    • The stutter happens regardless of framerate (75 fps, 140 fps, etc.)
    • The stutter happens at a specific time-interval (every 1.0s, every 0.25s, etc.)
    • The stutter time-interval exactly changes (ie. increases/decreases) as the "Sky Update Frames" setting changes (ie. stutter and "Sky Update Frames" setting seem directly linked to each-other)
    • The stutter gets worse the earlier the time (eg. 7:30 AM), and gets better (sometimes fully gone) the later in the day (eg. 7:30 PM)
    • The stutter goes away completely when either Time Scale or Shadows are fully off (one or the other, both don't have to be disabled)

    Those six points suggest to me that the issue is purely down to something with the game-engine related to day/night/shadow transitions. I was going to guess and say that perhaps there are too many static shadows at certain corners and/or camera angles because the PLR file says "Shadow Updates * Sky Update Frames should exceed number of static shadows on track" but the problem still occurred when I raised "Shadow Updates" to 32 (default: 8) so It's probably not that.
     
    Last edited: Nov 23, 2016
    • Agree Agree x 1
  10. Alex Sawczuk

    Alex Sawczuk Well-Known Member

    Joined:
    Feb 14, 2016
    Messages:
    1,029
    Likes Received:
    858
    It doesn't happen for everyone though. Can you post your full graphical settings in control panel and specification. Also you could send me your player profile.
     
  11. Spin

    Spin Member

    Joined:
    Apr 15, 2016
    Messages:
    197
    Likes Received:
    23
    I have noticed this for 2 years on different tracks/cameras (which have changed as updates came along) on the all the following equipment (I buy and sell a lot):

    Motherboards

    Asus Sabertooth X79
    ***Asus Rampage IV Gene***
    ASRock X99X Killer Fatality
    MSI X99S XPower

    Graphics Cards
    5x GTX 780 Ti
    3x GTX 970
    ***5x GTX 980 Ti*** (1x in current system)

    CPUs

    1x i7-3820
    ***3x i7-4930K*** (1x in current system)
    1x i7-5930K

    Operating System
    ***Windows 8.1 Pro 64-bit***

    RAM
    1866 MHz 8GB (4x4GB) Dual-Channel DDR3 @ 8-9-9-24-2T
    1866 MHz 16GB (4x4GB) Quad-Channel DDR3 @ 8-9-9-24-2T
    ***2133 MHz 16GB (4x4GB) Quad Channel DDR3 @ 9-11-10-28-2T***
    2400MHz 16GB (4x4GB) Quad-Channel DDR4 @ 11-11-11-27-1T

    Gaame Graphics settings
    I have everything maxed except AF @ 8x. SweetFX disabled. Tried 2x AA from Game, and disabled AA from game. I have experimented with all sorts of different graphics settings and the issue never goes away UNLESS I fully disable either Time Scale (none) or Shadows (full).

    My current setup has a *** beside each component above. It's also with a completely brand new full install of everything (Windows, games, etc.) Windows is on a Samsung 840 Pro 256GB SSD and the the game is on a Western Digital VelociRaptor 1TB HDD.
     
  12. Alex Sawczuk

    Alex Sawczuk Well-Known Member

    Joined:
    Feb 14, 2016
    Messages:
    1,029
    Likes Received:
    858
    Nvidia control panel settings?

    My system is a lower specification....
     
  13. Spin

    Spin Member

    Joined:
    Apr 15, 2016
    Messages:
    197
    Likes Received:
    23
    All default excpet Max Rendered Frames at 1. I tried with it a default, no difference. Tried with GSync disabled, no differece. Tried with ULMB, no difference. Tried with refresh set to application controlled, no difference. Tried with refresh set to max refresh rate, no difference. I've tried many differnt control panel, game, and in-game gfx settings over the years + many different hardware components (as mentioned above). The issue has never gone away, the only thing that ever affected it where game/track updates. It used to be real bad on some kart tracks, and then in some updates it went away on some kart tracks.
     
  14. Spin

    Spin Member

    Joined:
    Apr 15, 2016
    Messages:
    197
    Likes Received:
    23
    Some stuff came up over the weekend so I haven't had much time to test but this is what I got so far. I will only report big issues; 1 tiny stutter here or there which is almost impossible to notice will not be reported - just the big stuff. Test day in the afternoon with 0 opponents. TV cam is Group #1.

    Floripa
    Onboard
    - many corners around track as well as coming out of garage and heading down pitlane
    TV
    - same

    Brasilia
    - OK

    Buenos Aires 12

    Onboard
    - beginning of final straight (before final corner) throughout final corner and continuing on down the main/front straight where it goes away before turn 1
    TV
    - same
    - another corner or two around the track (I think leading up and partway through the long, fast right hander (after turn 1 chicane)

    Buenos Aires 15

    Onboard
    - [refer to Buenos Aires 12] but seems a little less severe than BA12 from back straight to main straight but that may be my mind
    - some other corners throughout the lap
    TV
    - same

    Buenos Aires 6

    Onboard
    - 2nd last corner (chicane) then [refer to Buenos Aires 12]
    - 1 or 2 short periods throughout the rest of the lap
    TV
    - Some corners throughout the lap

    Campo Grande
    - OK
    Caruaru - OK
    Cascavel - OK
    Cordoba - OK
    Curitiba - OK, (couple borderline areas)
    Curitiba Outer Circuit - OK
    Goiania both layouts - OK
    Guapore - OK


    I'll keep updating this post as results come in

    ***IMPORTANT UPDATE***
    - If you try Floripa at 7:30 AM (I had it set to track default before) then the stutters become much bigger. Watch as you leave the garage and head to turn 1. Also, notice how the stutter-timing doesn't change; the timing seems purely down to the number "Sky Update Frames" is set to.
    - I also tried at 7:30 PM and that has the opposite effect - the stutters are much less than the default time let alone 7:30 AM. So it seems the earlier the time, the worse the stutters get, and the later the time, the better the stutters get.
     
    Last edited: Oct 18, 2016
  15. rsr427

    rsr427 New Member

    Joined:
    Mar 15, 2016
    Messages:
    18
    Likes Received:
    4
    So, I've been getting the stuttering for quite a while, but I haven't minded it because I mainly goof around with AMS. But now with the Britpack soon upon us, I want to start doing championships. I've been reading a lot on the various fixes, have compiled them below, but still no luck. I was actually disciplined enough to try each, one at a time. My testing last night was with the Boxer, the StockCar, at Brasilia Oval and Kansai.

    Problem: every so often (at least once per lap, not at the same place) I get a 1/3 to 1/2 second stutter, otherwise the graphics are very smooth.

    1) dynHUD - turned this off a while ago
    2) set shadows to med - tried this and blur set to off
    3) ffb to 180hz - no difference, tho at 180 the wheel can oscillate terribly
    4) ntcore patch - installed and applied to AMS.exe, no luck
    5) change maximum prerendered frames to 1 - no difference
    6) vsync - tried on and off
    7) reinstall dx Automobilista\Support\DirectX\Install\dxsetup.exe - done
    8) check time progression - on normal, turned off, no change
    9) set frame limit to monitor refresh rate - done
    10) turn off spotter - same problem existed before and after spotter addition, d/n coincide with spotter talking
    11) set nvidia settings per manual - check
    12) remove and reinstall game - no change
    13) new user profile created - no change
    14) turned off antivirus software - no change
    15) turned on and off AA - no difference

    So, I have seen no difference to eliminate the stutter (though setting the frame limit to monitor refresh has improved general smoothness). Sounds like I'm kind of screwed, which is too bad considering how much I am looking forward to Britpack and the other DLCs. And if I go back to online racing, it would likely be with AMS. My system specs are below. Please let me know if I missed anything or if you can commiserate.

    Specification Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
    RAM1 Manufacturer (ID) PNY Electronics (7FBA0000000000000000)
    Size 8192 MBytes
    Max bandwidth PC3-12800 (800 MHz)
    RAM2 Manufacturer (ID) PNY Electronics (7FBA0000000000000000)
    Size 8192 MBytes
    Max bandwidth PC3-12800 (800 MHz)
    HD1 Name PNY CS1311 240GB SSD
    Capacity 223.6 GB
    HD2 Name TOSHIBA-TR150
    Capacity 894.3 GB
    GFX Name NVIDIA GeForce GTX 980 Ti
    Board Manufacturer EVGA Corp.
    Memory size 6 GB
    Memory type GDDR5
    Windows Version Microsoft Windows 10 (10.0) Home 64-bit (Build 14393)
    DirectX Version 12.0
     
    Last edited: Oct 29, 2016
    • Useful Useful x 1
  16. Erick Goldner

    Erick Goldner Active Member

    Joined:
    Mar 9, 2016
    Messages:
    464
    Likes Received:
    107
    Nice dedication on it!

    Since you've tried already many things, what i see that's is missing is the Driver Version and the Nvidia Control Panel settings.
    You could maybe try a different driver version and as well check if you're using the recommended settings for the control panel from the Manual (page 19).
     
  17. rsr427

    rsr427 New Member

    Joined:
    Mar 15, 2016
    Messages:
    18
    Likes Received:
    4
    Updated my nvidia drivers and followed the Manual's advice to configure the settings. Still get the stutters. At least once per lap. For a time, I thought it was sound related. I'd run wide at a corner, and when I hit the dirt and it triggers that sound it would stutter. But its not isolated to that though. (and having the spotter in the latest build has not affected it)

    I tried putting the grfx to the "basic" preset and though the game still looks good, no luck in eliminating the stutters.

    When I review replays, the stutter seems to be captured in there. Is there a way to record what the game is doing and sync it up with the video to find the stutter? I'm at my wits end, I want to start racing this soooooo bad but I am hamstrung by these stutters.
     
  18. Erick Goldner

    Erick Goldner Active Member

    Joined:
    Mar 9, 2016
    Messages:
    464
    Likes Received:
    107
    I know it might be crazy but, have you already tried to delete the config.ini file and also start a new profile?
     
  19. rsr427

    rsr427 New Member

    Joined:
    Mar 15, 2016
    Messages:
    18
    Likes Received:
    4
    I uninstalled the game and just redownloaded and I get the same thing.

    I will delete the config and attempt a new profile. Worth trying...
     
  20. Supa

    Supa Member

    Joined:
    May 5, 2016
    Messages:
    98
    Likes Received:
    14
    Can I make a suggestion.When I set the FPS limit ingame to say 120 or even 90 my GPU works alot less intensly. Also your driver is a big issue here. I use an old Gigabyte driver version 347.09.....latest nvidia is 375....... as my gtx760 is aftermarket and it out performs the latest nvidia driver by miles. I tested this yesterday. And make sure you first set up control panel properly before going to nvidia profile. Good luck!
     

Share This Page