1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stuttering issues - discussion & suggestions

Discussion in 'Automobilista - Help & Support' started by Spin, Oct 9, 2016.

  1. Chris Stacey

    Chris Stacey Active Member

    Joined:
    Jun 17, 2016
    Messages:
    103
    Likes Received:
    29
    Oh nice, I didn't know this. I thought it was to skip the intro movie on game boot up.
     
  2. vveyro

    vveyro New Member

    Joined:
    Apr 27, 2017
    Messages:
    27
    Likes Received:
    9
    You can do that, by just deleting the video file in Automobilista/MovieFiles. Doesn't cause any issues and effectively skips the intro
     
  3. Chris Stacey

    Chris Stacey Active Member

    Joined:
    Jun 17, 2016
    Messages:
    103
    Likes Received:
    29
    Yeah I did that ages ago :)
    I just thought this might be like an "official" way of doing it haha
     
  4. Scraper

    Scraper Active Member

    Joined:
    Aug 9, 2016
    Messages:
    243
    Likes Received:
    93
    But I like the "schum-schum-boom"... :)
     
    • Funny Funny x 1
  5. Tr51

    Tr51 Member

    Joined:
    Mar 10, 2016
    Messages:
    30
    Likes Received:
    2
    I ask: can not you still eliminate stuttering?





    ..... Yes !!!
    In my case I disable time scale, put FPS 117 and turn off Spotter.

    ... but I'm not satisfied
     
    Last edited: May 13, 2017
  6. vveyro

    vveyro New Member

    Joined:
    Apr 27, 2017
    Messages:
    27
    Likes Received:
    9
    My audio related stutters went away after installing on SSD. On HDD there was notable delays when spotter audio was played. I can use spotter if I want now, although I use CrewChief.

    For me most of the problems went away by putting FPS cap to 97 and auto-detail FPS to 67, VSync on (my screen refresh is 60 Hz) although I dislike VSync generally. I disabled also the replays. Time scale I've used on Race % and sometimes off, it feels to me regardless of what I use there is always some slight stutters. Also deleted the d3d9.dll from steamapps/common/Automobilista folder, so there is no DynHUD which I've heard can help.

    Not related to stutters maybe but more FPS, Max Shadows seem to be really demanding. A shame, they look much better than High shadows. I had to reduce visible headlights from the .ini file to make night racing playable.
     
    Last edited: May 13, 2017
    • Informative Informative x 1
  7. Tr51

    Tr51 Member

    Joined:
    Mar 10, 2016
    Messages:
    30
    Likes Received:
    2
    thank you for tips
     
  8. sherpa25

    sherpa25 Member

    Joined:
    Mar 11, 2016
    Messages:
    111
    Likes Received:
    3
    Can you show where and how much adjustment you made for headlights? Thanks.
     
  9. vveyro

    vveyro New Member

    Joined:
    Apr 27, 2017
    Messages:
    27
    Likes Received:
    9
    My Documents/Automobilista/USERDATA/Yourname/Yourname.PLR file

    Open in text editor or Notepad, search (ctrl+F) for line

    Max Headlights="20" // Max headlights visible relative to your car.

    Replace 20 with some number. I put it to 10, but you can put it even to 2. Will look a bit odd, but the smaller number, the better performance. With 10 I barely notice that distant cars don't have headlights, because the cars I'm chasing have them. Closest cars to you will be having lights.

    You can also change Headlights on cars="1" into 0, that will look very odd (headlights won't light up other cars in front of them), but improves performance even more. I left that on.
     
    • Like Like x 1
  10. Tr51

    Tr51 Member

    Joined:
    Mar 10, 2016
    Messages:
    30
    Likes Received:
    2
    Hmmm ... after more thorough tests, there is nothing to do, Stuttering still appears

    With VSync there! (With three @ 144Hz monitors)
    No VSync there !!
    Capped frame at 109 \ 120 \ 127 \ 135 \ 144 ... always appears randomly
    Deleted d3d9_2.dll ... has changed nothing
    Disabled Spotter .. nothing
    Shadows off ... nothing
    Low shadows ... nothing
    shadows medium .. nothing
    High shadows (very strong.... but nothing)
    Among other things I noticed that low shadow is on the circuit but not under the car;
    Medium shadow is under the vehicle but not on circuit .... (is it correct?)

    General Settings :

    FSAA = 4 ( also tried a " 0 " But it does not change )
    VSync = 0
    ShaderLevel = 3
    Subviews = 0
    -
    Shadows = "2"
    Shadow Blur = "0"
    Shadow Cache = "1"
    Pitcrew Detail = "2"
    Special FX = "2"

    Ps: even with all the low graphics settings ... there is nothing to do; Stuttering is always there
    rFactor 2 no issue (DX11_Beta)
    Assetto corsa no issue
    iRacing no issue
    LFS no issue
    Project cars no issue
    RaceRoom Racing Experience no issue
    F1 2016 no issue
    DiRT Rally no issue
    GT legends no issue
     
    Last edited: Jun 14, 2017
  11. Tr51

    Tr51 Member

    Joined:
    Mar 10, 2016
    Messages:
    30
    Likes Received:
    2
    OMG

    solved
    I found the guilty !!!
    In the UI, steering wheel = off !! The stutter disappeared :)
    I can keep DynHUD active :eek:

    unbelievable
     
    • Like Like x 2
  12. Richard963

    Richard963 New Member

    Joined:
    Apr 25, 2016
    Messages:
    27
    Likes Received:
    13
    Great!!! Glad you solved the problem.
    I'll try your solution later.
     
  13. roby13

    roby13 Active Member

    Joined:
    Mar 8, 2016
    Messages:
    154
    Likes Received:
    37
    Whaaaaat? Never heard about it.
     
    • Dislike Dislike x 1
  14. Tr51

    Tr51 Member

    Joined:
    Mar 10, 2016
    Messages:
    30
    Likes Received:
    2
    There is always the first time for everything
     
  15. Richard963

    Richard963 New Member

    Joined:
    Apr 25, 2016
    Messages:
    27
    Likes Received:
    13
    Tr51 - Thanks again for your help, but turning off the steering wheel didn't cure the "DynHUD" stuttering on my system.

    I can only solve the stuttering problem by deleting (renaming) d3d9.dll.
    GID Hud's d3d9.dll works fine.
     
    • Agree Agree x 1
  16. vveyro

    vveyro New Member

    Joined:
    Apr 27, 2017
    Messages:
    27
    Likes Received:
    9
    Actually, developer posted this on another thread:
    And I actually think *this* is what cured my stutter (leaving intro video in place). I had deleted it earlier, to speed up the loading, but then did Steam integrity check and didn't delete it again. My stutters were gone around the same time.

    Maybe doesn't work for most, but something worth trying if you have removed the intro video.
     
  17. Tr51

    Tr51 Member

    Joined:
    Mar 10, 2016
    Messages:
    30
    Likes Received:
    2
    Thanks for advice

    However I did not remove the file "PreGame.bik"
    The only way to eliminate (not entirely) stuttering (in my case) is "steering off " in UI; but the cars with non-analog speedometer bring stuttering.
     
  18. Dady Cairo

    Dady Cairo New Member

    Joined:
    Jun 12, 2017
    Messages:
    20
    Likes Received:
    0
    So,i had the stuttering to on a Lenovo Y 700 Gaming Laptop.
    1.Defently the spotter cause it!Deaktivat it or put the game on a SSD HD,then it is gone!
    2.Steering wheel seems related to the video Driver,switched to the older Nvidia 376.67,then its gone!
    3.Vsync in game config to OFF,then switch Vsync ON in Nvida controlpanel.Works best with FPS around 110!Little less tearing in the Background.Also AA 4x 2x Supersampling.
    Now,that is what worked for me,all Problems solved.
    Cheers
    DC
     
    • Useful Useful x 1
  19. max1966

    max1966 New Member

    Joined:
    Mar 9, 2016
    Messages:
    10
    Likes Received:
    0
    I play a bit infrequently and was disappointed to experience this stuttering on two separate installs to lesser or greater extent.

    At home with a wheel running AMS the stutter was accompanied by screen tearing. I removed my current profile, d3d9.dll and created a new profile on start up. Left all of the settings as standard but turned time scale to none. Stuttering and tearing disappeared. I re-installed d3d9.dll and although the FPS took a bit of a hit no stutter or tearing and a functioning DynHud.

    At 'work' on AMS Beta with a controller I experienced stutter so disabled time scale, and it was gone. I made no other changes but when I put the time scale back on race % it returns.

    Perhaps this isn't the only culprit but for me it has worked.
     
  20. Will Mazeo

    Will Mazeo Active Member

    Joined:
    Mar 8, 2016
    Messages:
    542
    Likes Received:
    137
    Yes, we ran our leagues without time scale for 2 months, we turned it off to test if this was causing the issue. First race we turned it on again and some guys had stutter.
    It's russian roulette, some people will never have it, some will do. I recommend just never using it, disappointing but has to be done.
     

Share This Page