1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stuttering issues - discussion & suggestions

Discussion in 'Automobilista - Help & Support' started by Spin, Oct 9, 2016.

  1. Ctrlvr

    Ctrlvr New Member

    Joined:
    Sep 10, 2017
    Messages:
    11
    Likes Received:
    0
    Hi,

    From the offset just wanna say this game is awesome - leaves rfactor2 for dust imo!

    Got a stuttering issue though - have also tried everything in this thread, from every other Automobilista thread on the planet, and also my own DIY detective work and nothing resolves it!

    The stutter is always there but becomes much more noticeable at corners on all maps. For example I start a race in Nurburgring I approach the first corner and bring my speed down to 10mph and do a very slow 360 turn and I can see the stadium doing a precise stutter around me when the stadium is moving around the car - as if in organised segments. In the intro section when it shows areas of a track the helicopter flying bye stutters...

    So I gave up after devoting about 5hrs solid to it - I then came to this thread 1 more time and noticed someone said 'steering wheel off resolved it' - I went to game and noticed my steering wheel in cockpit view was weird looking and looked more like a rectangle blank square. Now, before I go any further I just want to state that the nose or cockpit view has always been a bit hit and miss to select in settings as in sometimes it works then sometimes it doesn't - that in itself has always been an issue for me. Right, so I switched off steering wheel and it gives a weird wobbly track view off just the track (no nose nor cockpit) I then switched wheel back on and it stays in this view. I then changed car config to get my normal view back and I'm permanent stuck in this view and now the game is totally unplayable - I've rebooted computer to flush memory but no joy. However, I did noticed the original stadium/corner stutter issue was sporadic (sometimes better/sometimes same) in this new problem I have. So, I could be wrong, and I'm not sure, but the steering wheel view settings may (just may) have something to do with the main stuttering issue users experience.

    Other than that - I'm loving the game and these Ibarra map is awesome to look at! And whilst here just want to add this game maxed out on 4k looks awesome - and yes before anyone says I have tested everything at lower settings and still stutter!

    Hope this helps.
     
    Last edited: Sep 10, 2017
  2. Ctrlvr

    Ctrlvr New Member

    Joined:
    Sep 10, 2017
    Messages:
    11
    Likes Received:
    0
    Also, I've noticed in the Automobilista config file it says 'system ram=2044' - I have 32gb in my system; could that be an issue?

    It's not worth me checking as I'm now stuck in this new broken unplayable view!
     
  3. Dean Ogurek

    Dean Ogurek Active Member Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    286
    Likes Received:
    81
    I just saw a post stating that MS has acknowledged some recent Win10 updates contributing to game stuttering issues and they are investigating.
     
  4. Ctrlvr

    Ctrlvr New Member

    Joined:
    Sep 10, 2017
    Messages:
    11
    Likes Received:
    0
    That's for the reply and that's good to hear.

    One thing I didn't try, and now I have, is disabling that dll file for the dynamic - what a massive difference! The stutter has reduced by over half 100% of the time - far more playable but still a laggy stutter going around corners but it's much better!
     
  5. Ctrlvr

    Ctrlvr New Member

    Joined:
    Sep 10, 2017
    Messages:
    11
    Likes Received:
    0
    Just an update for anyone else having the same issue - adaptive sync, dynahud off, change the dll file associated with dynahud...

    "Easiest way is by remove/rename (for example by putting dot at the beginning of the filename) d3d9.dll in the Automobilista main folder."

    ...so it doesn't work anymore and set the in-game FPS limit to 75 if you're playing on a 60hz TV like me. Doing this has now given me 100% smooth no stutter play.

    I have shadows set to medium, got the time thing set to off as well - I'm gonna switch it back on as I don't think that's the issue, everything else is maxed to ultra apart from car opponent detail which is set to high. Anyway 75 FPS is the magic number for me - any more or less and it messes up! Playing 4K as well.

    i7 6700k and gtx1080
     
    Last edited: Sep 12, 2017
  6. Spin

    Spin Active Member

    Joined:
    Apr 15, 2016
    Messages:
    207
    Likes Received:
    25
    Weird. If your framerate doesn't match your monitor's set refresh rate then you should be getting a consistent timed stutter regardless of the game's settings because of the unmatching framerate to refresh rate.

    What DLL file are we supposed to be change? Change it to what?
     
  7. Ctrlvr

    Ctrlvr New Member

    Joined:
    Sep 10, 2017
    Messages:
    11
    Likes Received:
    0
    Precisely - that's what should happen! In my experience I cannot play with normal vsync on whatsoever as it gives me a perfectly timed continuous lag every other second totally unplayable. When I put it on adaptive not as bad but I still had the perfect stutter going around corners, doing slow 360 turns in front of stadium, plus going by track fencing - very noticeable but not as noticeable driving down straights - still annoying!

    When I turn off dynahud and put it to original instead and did the below...

    "Easiest way is by remove/rename (for example by putting dot at the beginning of the filename) d3d9.dll in the Automobilista main folder."

    ...I had massive improvement in adaptive vync and normal vsync was improved but still not good enough. In adaptive sync corner stutter now totally stops and the slow 360 test shows massive improvement - but I still needed to get rid of the continuous sporadic screen tears which pop up when racing. I matched up all numbers everywhere to 60 (TV, computer, game) then 59, then 49, 59, 51, 65, 100, default 120 etc.. and everything else 60 - I also read that matching prime numbers should be used - none resolved the screen tears and finally I use adaptive sync, put in 60 refresh for tv in Nvidia, 60 refresh in Automobilista config tool, and '75' FPS limit in the game main setup screen and now perfect smooth! This game is played on a 60hz 4K TV setting.

    I think game has syncing issues for some systems and dynahud also messes up system sources up for me and quite a few others.

    On 4K 60hz TV - switch off dynahud, change dynahud dll name, adaptive sync, 60 refresh TV setting, 60 Automobilista refresh rate config tool, 75 FPS setting in game - worked for me!

    All of the above was experienced and done whilst timesale was set to off and shadows medium - i'll try it set to on later and will report results.
     
    Last edited: Sep 12, 2017
  8. Alex Sawczuk

    Alex Sawczuk Well-Known Member Reiza Backer

    Joined:
    Feb 14, 2016
    Messages:
    1,029
    Likes Received:
    858
    You are also disabling SweetFX there. You have to rename d3d9_2.dll to d3d9.dll to keep it.
     
  9. Ctrlvr

    Ctrlvr New Member

    Joined:
    Sep 10, 2017
    Messages:
    11
    Likes Received:
    0
    Thanks for that - my eyes have been glued to the screen so much resolving my issue that I didn't notice the difference.

    The only other unrelated issue is when I play a race against the if f I set it to drive with 15 cars then sometimes ahead in the distance of me, and on corners, one or two of the AI cars disappear for a second then reappear. I set to 12 cars same problem, 10 same problem but when set to 8 total cars in race (me included) no disappearing cars whatsoever. Any advice for that? I can live with it - no problem, but if there's a simple fix then great!
     
  10. Alex Sawczuk

    Alex Sawczuk Well-Known Member Reiza Backer

    Joined:
    Feb 14, 2016
    Messages:
    1,029
    Likes Received:
    858
    That just sounds like the 12 closest cars are changing a lot, so they pop in and out... A 8 visible cars, maybe the field was more split up, dunno.
     
  11. Spin

    Spin Active Member

    Joined:
    Apr 15, 2016
    Messages:
    207
    Likes Received:
    25
    Ok so can I safely rename/delete d3d9.dll in the main automobilista install folder (steam>steamapps>common>Automobilista) if I don't use dynahud nor sweetfx?

    And if I want to still use sweetfx then also rename d3d9_2.dll to d3d9.dll?

    Are those both correct and is there anything else that gets disabled when renaming/deleting the original d3d9.dll
     
  12. Ctrlvr

    Ctrlvr New Member

    Joined:
    Sep 10, 2017
    Messages:
    11
    Likes Received:
    0
    I renamed the following file by putting a dot in front which prevents file been used - I haven't deleted it. I'll do what Alex says with sweetfx later today.
     
  13. Ctrlvr

    Ctrlvr New Member

    Joined:
    Sep 10, 2017
    Messages:
    11
    Likes Received:
    0
    Okay - I did what Alex said with the sweetfx file and it gives me lag/stutter - not that bad tbh and nowhere near as bad as the original stutter. I've gone back to what I did in my original solution as that works best for me.
     
  14. Msportdan

    Msportdan Well-Known Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    1,179
    Likes Received:
    273
    guys its not W10 its not fps not matching refresh rates its not gpu drivers or gfx settings..

    Its time scale set to anything other than none.

    I have a 1080 maxing out at 144fps on a Benq (144hz) the time scale set to none eliminates all stutter. Also the fact that this has been in AMS since GSCE days its defo not w10 related.

    Ive noted this in the Beta forums, but its been around for a while and thought the time scale stutter bug, thing was fixed a while back, its been reintroduced it seems along the way.
     
  15. Will Mazeo

    Will Mazeo Active Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    653
    Likes Received:
    173
    Yep, known reason for a long time and there is no fix coming. Turn off time scale and play it smooth
     
  16. Ctrlvr

    Ctrlvr New Member

    Joined:
    Sep 10, 2017
    Messages:
    11
    Likes Received:
    0
    Time scale was one of the very first things I turned off - no difference still stutters and tears. I left timescale off anyway and only after I did all of what I listed above did I achieve smoothness - it's great now. I'll leave my working game as it is and I'll switch on timescale to see if there is a change. In an Arnie style voice "I'll be back" - with the results tomorrow.
     
  17. Spin

    Spin Active Member

    Joined:
    Apr 15, 2016
    Messages:
    207
    Likes Received:
    25
    I'm nitpicking here :) but it's not necessarily time-scale itself that's the issue, it's timescale in combination with shadows when the issue occurs. So you can still use time-scale but then you'd have to disable shadows fully (not low but disabled). It sucks cause I'm a huge fan of time scale. I usually have my "default" time-scale set as either 2x or 3x and have my sessions start around 3 PM so they go from daytime to a nice low sunset where it gets close to the point of having to use headlights but I now mostly play with time-scale off because of the issue :(
     
    • Agree Agree x 2
  18. tpw

    tpw Active Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    224
    Likes Received:
    128
    IMHO the CPU hungry shadow handling (particularly in combination with time scaling) is probably the greatest graphic weakness of AMS. It's 2017 for deity's sake, it shouldn't be too much to ask for the passage of time, and reasonable shadows that don't cripple FPS. Roll on Reiza 2018 so we don't have to have this discussion:)

    Personally I can't do without shadows, so my compromise is to lose the time scaling. Without time scaling I can run full shadows in cockpit view with no stuttering, but may need to switch to high shadows for replays. I find that cars with complicated geometry (eg the formula vee with all its exposed bits and pieces) will cause bad replay stuttering with full shadows but a tin top car with simpler geometry Is usually ok.
     
  19. Ctrlvr

    Ctrlvr New Member

    Joined:
    Sep 10, 2017
    Messages:
    11
    Likes Received:
    0
    Put timescale back on and shadows set to medium and doesn't break anything - you guys sure you haven't had timescale off needlessly as it may have been fixed a while ago?

    I agree with poster tpw before me - maybe CPU issue. I also notice that when I use Caterhams I get tiny bit of stutter and maybe that's down to the geometry of the Caterhams making CPU work harder. Tintops and formula style cars are fine. Also maybe CPU issue why I can only use max 10 cars including me - anymore and I have teleporting cars!

    Still, best car game I've played in years and the handling is superb and I just played F1 2014 and the graphics sucked bad in that and I booted up Automobilista and the graphics in 4K are great - better than Rfactor 2; maybe just upgrade the racing fans a little on the roadside...
     
  20. Will Mazeo

    Will Mazeo Active Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    653
    Likes Received:
    173
    No, shadows at any level can cause this, if you dont have (I dont have that either) be happy.
    In our leagues I turned off time scale because of that, some people have this problems, some others dont. When you have it the only way to avoid is either time scale off and shadows on or the contrary.
    Already proved this in our leagues after running with this off for 2 months no issues reported, first race we had this on again and 2 guys had problems, and their PCs were good.
    As said before, this is a known issue and shadows update are the known cause (when the problem is caused by time progress). Some people have issues caused by other things like DynHUD, the spotter also used to cause problems for others but I think this has been solved by Reiza.
     
    • Agree Agree x 1

Share This Page