1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stuttering issues

Discussion in 'Automobilista - Help & Support' started by OlivierMDVY, Aug 25, 2016.

  1. Jan Mikuž

    Jan Mikuž Active Member Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    475
    Likes Received:
    53
    Oops, sorry. Try now, Renato. :)

    I think i got the issue from the video sorted now, though.
    I suspect some residue from old game profile, AA conflict or smth like that...

    Anyway, I'm testing the game freshly setup now (no fresh install, but fresh game profile,
    config tool reset, SweetFX 'Original' setting, 60VsyncOn, Ultra settings,
    fps limit 100 in game) and stutter seems to only appear under specific circumstances now.
    Will report back tomorrow.
     
    Last edited: Aug 28, 2016
  2. Jan Mikuž

    Jan Mikuž Active Member Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    475
    Likes Received:
    53
    I edited my last post. Will report back tomorrow.
    Or later today, should i say, since it's 2am, lol. :)

    Cheers.
     
  3. GTSpeedster

    GTSpeedster FOV Geek Reiza Backer

    Joined:
    Jul 20, 2016
    Messages:
    49
    Likes Received:
    75
    I'm also having issue with FPS as well. In fact the sim has become completely unplayable since I'm getting only between 5 or 8 FPS once the race begins.

    I'm running without sweet fx and even after turning virtually everything off or to its minimum value in NVIDIA inspector and ALL of display details to their lowest values I still can't get more than 10 or 12 FPS.

    Toggle an instant replay however and I can get way beyond 250 FPS right away.

    I even tried deleting the DynHUD (folder and its dll) from the plugins but it didn't impact my FPS count at all.

    I'm out of ideas as to what's causing such a massive FPS drop since I last ran it a couple of weeks ago.
     
  4. sherpa25

    sherpa25 Member Reiza Backer

    Joined:
    Mar 11, 2016
    Messages:
    120
    Likes Received:
    3
    Wow, with that gear? FWIW, do you have MSI afterburner running?
     
  5. GTSpeedster

    GTSpeedster FOV Geek Reiza Backer

    Joined:
    Jul 20, 2016
    Messages:
    49
    Likes Received:
    75
    Yeah, I think we can rule out lack of punch as the most likely cause for the issue... :rolleyes:

    And yes, even running a more aggressive overclocking setting that I sometimes use within the afterburner didn't seem to have any effect.

    In the mean time I've also performed a clean NVIDIA driver update and have tried running the sim without the SimXperience' Sim Commander in the background, but I'm still getting between 5 and 12 FPS regardless of what graphical settings or levels of detail I change.

    :(
     
  6. rocafella1978

    rocafella1978 Member Reiza Backer

    Joined:
    May 22, 2016
    Messages:
    87
    Likes Received:
    10
    just wanted to throw this in here, since the other thread:
    Weird stutters

    has received no feedback from Reiza support, we are still hopping around and getting heavy stutters.
    (i deleted everything and all related to dynhud, at least from what I knew belongs or is needed to run dynhud, since nobody answered what "solely" is used by dynhud and is safe to delete!)
     
  7. GTSpeedster

    GTSpeedster FOV Geek Reiza Backer

    Joined:
    Jul 20, 2016
    Messages:
    49
    Likes Received:
    75
    I think I've figured out what's causing my FPS issue.

    It seems to be related to the number of USB peripherals you're allowed to run as well as to the amount of input/data/feedback that the game seems to be moving around in relation to your gear/hardware.

    What do I mean? Well, like I said earlier no matter what I tried software or settings wise I was stuck at extremely low FPS, between 5 and 15... But the moment I simply unplugged one of my shifters the sim immediately allowed me to run at +60 FPS.

    That got me thinking and I decided to try and lower the force feedback effects from "pure 360hz" to "pure 180hz" and it then let me to run the game at even higher FPS without any obvious stuttering.

    All I can say for sure is that a few weeks ago I was able to run this title with the very same hardware and peripherals connected, already running the game at "pure 360hz", without FPS issues of this magnitude.

    Therefore I believe it's got to be a bug related to having the sim now transferring larger amounts of data at higher rates than it was doing before (or something along those lines as I lack the proper vocabulary).
     
    • Like Like x 1
  8. rocafella1978

    rocafella1978 Member Reiza Backer

    Joined:
    May 22, 2016
    Messages:
    87
    Likes Received:
    10
    who deleted or why did the other THREAD about stutters and FPS problems started by @Jan Mikuž get deleted?
    image.jpeg
     
  9. rocafella1978

    rocafella1978 Member Reiza Backer

    Joined:
    May 22, 2016
    Messages:
    87
    Likes Received:
    10
    thx @GTSpeedster, this is worth trying!
     
  10. Scraper

    Scraper Active Member Reiza Backer

    Joined:
    Aug 9, 2016
    Messages:
    325
    Likes Received:
    167
    I hope this means we will see more of your great videos. ☺
     
    • Friendly Friendly x 1
  11. rocafella1978

    rocafella1978 Member Reiza Backer

    Joined:
    May 22, 2016
    Messages:
    87
    Likes Received:
    10
    a little disappointed that Reiza is not posting anything at all, are these isolated issues? from what i can see apart from the official Reiza forum, it is all over the "usual" forums about massive stutters to micro stutters...and not only a few people.
     
  12. hex

    hex Damage, Inc. Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    162
    Likes Received:
    108
    From what I noticed: FXAA mess with the menu pretty heavily, I had tons of UI flickering when FXAA was on. Try disabling it in the graphic's control panel.
     
  13. rocafella1978

    rocafella1978 Member Reiza Backer

    Joined:
    May 22, 2016
    Messages:
    87
    Likes Received:
    10
    i did turn it off now, what exactly is FXAA for? thanks for pointing to that. will test it out. hoping also for Reiza to provide some help in this sooner than later.
     

    Attached Files:

    Last edited: Aug 28, 2016
  14. Jan Mikuž

    Jan Mikuž Active Member Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    475
    Likes Received:
    53
    Rocca, also note it's Sunday. ;)

    Tested a couple of tracks. The worst is Kansai, so i decided to try to test on Kansai.
    Test environment Boxer@Kansai East:

    - Vsync On (60hz), sweetFX OFF, basic gfx :
    Stutter all over the track, it's worst when turning in/during turns, straights not as severe,
    but still occasional twitching and slowdowns (is the case on all of the tracks).
    The twitching in turns is especially game breaking and therefore unplayable.
    The fps hardly drops, but it does jitter, especially when stutters are occurring.

    - Vsync OFF, sweetFX OFF, basic gfx :
    No major stutter, but the gameplay feels muddy and slowed down.
    FPS shows a stable 100 (limited in game).
    The slowdown especially noticeable when turning in/during turns. While going straight/on the straights the gameplay feels fairly smooth. Still unplayable, due to the all round slowed down
    performance - it doesn't feel like smooth gameplay at all. Especially apparent in turns, as noted.
    Tried upping the gfx to medium preset and stutter/twitching/stop and go motion
    immediately reappears.


    Conclusion:

    The only time i'm able to alleviate stutter/twitching/stop and go motion with Boxer@Kansai
    combo is with the following settings: VSYNC OFF, SWEETFX OFF, BASIC GFX PRESET.
    Unfortunately the gameplay/picture rendering(?) is muddy and slowed down and obviously still
    not running properly.
     
  15. Msportdan

    Msportdan Well-Known Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    1,179
    Likes Received:
    273
    Try setting the maxframerate to your monitors rate ie 60
     
  16. Renato Simioni

    Renato Simioni Administrator Staff Member

    Joined:
    Feb 14, 2016
    Messages:
    1,983
    Likes Received:
    6,660
    It wasn´t deleted, both threads were merged as they discussed the same topic.

    We have posted on the subject several times BTW, part of the reason why its helpful not to create multiple threads on the same topic . This is not an universal issue and there´s no universal solution, although there are a few common recommended measures. We´re compiling some to include in the manual, I´ll post it here as soon as I´m through with it.
     
    • Like Like x 1
  17. Jan Mikuž

    Jan Mikuž Active Member Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    475
    Likes Received:
    53
    That's the same as the ''fps limit'' option in the game.

    Will try different fps limit values and see if that has any effect on the performance.
    Already tried 60 and that one reintroduces stutter and also screen tear.
     
    • Agree Agree x 1
  18. rocafella1978

    rocafella1978 Member Reiza Backer

    Joined:
    May 22, 2016
    Messages:
    87
    Likes Received:
    10
    thx for all the updates I have tried basic gfx, med gfx, ultra gfx, sweetFX on/off and FXAA on/ off, vsync on/ off, my normal TV with 1080p @60 with acer predator 1440p @144, limiting Framerate in UI (in game) to 1.5x, or just max, nothing has worked. tried the same with win 8.1 pro 64 2-SLI nvidia gtx titan x (and no SLI), fanatec csw v2+csp v2 and win 10 pro 64 with asus 1080 strix, logitech G29. nothing has changed or worked. (i can write up specs and all, doesn't help, since v0.9.8 on AMS all and both worked flawless and both systems work like a charm on all "other" sim racing games) only since v1.0 all these issues have come up on AMS. anyways reporting it and writing it up here hope it helps you guys at Reiza and maybe there are workarounds. until then off to other sims...
    i did spent this weekend only on this AMS stuff and is exhausting and frustrating...

    in german we say "ich komme mir verarscht vor" in regards to v1.0 and perks being sent out by Reiza (so they claim) different topic but adds to the current frustration...
     
  19. Jan Mikuž

    Jan Mikuž Active Member Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    475
    Likes Received:
    53
    My updated status (Boxer@Kansai East):

    Vsync ON: Nothing works. Nothing helps alleviate stutter. Basic gfx with shadows OFF and stutter still present. Fps limit set to OFF/150 nothing changes. Didn't yet manage to find a measure that would make a difference. Right now Vsync ON doesn't seem to be an option for me at all and i'm done with this option for the time being.

    Vsync OFF
    : Managed to substantially reduce stutter by setting shadows to medium.
    Now i only get this muddy feel i already talked about, but with greatly reduced stutter and twitching.
    I suspect this muddy/low fps feeling may as well just be a replacement symptom for the stutter.
    I don't know...Well, It's at least somewhat playable now. :)

    I will take a break now. :)
     
  20. turbotape64

    turbotape64 New Member

    Joined:
    Aug 28, 2016
    Messages:
    4
    Likes Received:
    3
    Hi
    I had similar stuttering issue with v1.0. My solution was reinstall Directx drivers. Those drivers you can found at Automobilista\Support\DirectX\Install\dxsetup.exe
     
    • Like Like x 1

Share This Page