1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VR Discussions, Questions & Feedback

Discussion in 'Automobilista 2 - General Discussion' started by Heitor Facuri Cicoti, Apr 5, 2020.

  1. mr_belowski

    mr_belowski Active Member

    Joined:
    Jun 19, 2016
    Messages:
    98
    Likes Received:
    113
    pCars2 used to do something similar - for a single frame the head rotation would be completely wrong - looking at the car floor, sky, or whatever. It was fixed though
     
  2. antoFPV

    antoFPV New Member

    Joined:
    Mar 29, 2020
    Messages:
    12
    Likes Received:
    3
    --
     
    Last edited: Jul 1, 2020
  3. Submentalbass

    Submentalbass New Member

    Joined:
    Jul 1, 2020
    Messages:
    3
    Likes Received:
    0
    Hi all new here just wanted to see if any one else has had same issues in vr. The game plays smooth as butter in day time 21 ai on kaylami with zero time progression now the issue seems to be with time progression enabled as the race becomes dusk with time progression on. Almost as soon as all lights turn on all the vehicles and dusk / night begins the frame rate is severely effected me and 2 friends have had this since ea and its been smooth as butter night to day and day to night and great experience. Settings are the same as we used on ea and all experiencing the same issue on 3 systems in vr and on pc monitor seems to be possibly a bug with v1. 0
     
  4. NMRaceman

    NMRaceman New Member Reiza Backer

    Joined:
    Feb 25, 2020
    Messages:
    4
    Likes Received:
    0
    I posted in another forum, but this is likely better here. I have an i7 processor, 16 GB RAM, 1660 GTX, and Odyssey+. In the early betas I got 60-80 FPS. The later betas were down around 45 FPS. Version 1.0 is still at 45 FPS.

    I have reflections and environmental maps LOW, Texture High or Med (no FPS impact), MSAA Low, Texture Filtering Trilinear, Car and Track Detail Medium, Particle Density Medium. Super sampling is set in game to 1.0, Steam SS is set to 100% with no additional SS for the game.

    I am using the Sharpness tweak as well.

    Thanks in advance!
     
  5. Mike1304

    Mike1304 Active Member

    Joined:
    Apr 17, 2020
    Messages:
    104
    Likes Received:
    26
    Tried the new v1.0 and unfortunately I loose some FPS compared to latest early access version.
    There’s also some strange thing: everytime I start the game via Pi-Tool it starts SteamVR and the Game (Steam) BUT it also opens Oculus Home!?
    Had a Rift before I got my new Pimax but I don’t want to uninstall Oculus software because with Pimax I still can play my Oculus games.

    Don’t know why Automobilista 2 always launches Oculus home though!?
    If I close Oculus Home my AMS2 also shuts down!?
    Any Pimax users out there who can tell me if they have the same problem? If not: what could be the problem on my side?
    Could be that this causes extra performance impact (SteamVR AND Oculus Home open in the background...).
    Any Ideas?
     
    • Agree Agree x 2
  6. Alegunner68

    Alegunner68 Active Member Reiza Backer

    Joined:
    Dec 21, 2019
    Messages:
    393
    Likes Received:
    138
    White lines are flickering at interlagos and brands in the release build, possibly more tracks.
    Didn't see that in the betas.
     
    • Agree Agree x 1
  7. torsteinvh

    torsteinvh New Member Reiza Backer

    Joined:
    Jul 3, 2019
    Messages:
    8
    Likes Received:
    1
    Anyone else here with a Vive Cosmos?

    Did some quick testing late last night, and my Vive Cosmos seems to be locked at 45 FPS according to fpsVR... Looks just like when I was using reprojection on my old Odyssey+.
    Very strange, as the Cosmos doesn't support reprojection yet as far as I know...

    Before the 1.0 release of AMS2 my FPS in VR varied a lot more with the same settings...
     
  8. NMRaceman

    NMRaceman New Member Reiza Backer

    Joined:
    Feb 25, 2020
    Messages:
    4
    Likes Received:
    0
    I'm wondering if the locked to 45 FPS is part of the new windows or Steam VR update.
     
  9. jpmmuc

    jpmmuc Active Member Reiza Backer

    Joined:
    Aug 29, 2016
    Messages:
    172
    Likes Received:
    59
    AMS 2 in VR is as good as before incl. newest beta SteamVR version and Windows 10 v2004. No drawback and the same performance as before.

    I really think that most people are dialing the settings to high. After using VR now for a few years I see that most tips are using to high settings. Focus on performance vs. graphics fidelity while dialing in the settings.
    Also consider that tracks with more details needs more power so you should really go not to high with the settings. Mainly night with this added light sources even it's darker on the track needs a lot more power than sunny daylight.
    AMS 2 has implemented some steps for performance like the 2D trees which help really and beside that are looking really good.

    Simplest settings for performance are things like Detailed Grass = off or Shadow Details = low and reduce the number of AI to 19 or down to 9. Also use the in game supersampling setting of the VR setting and not external supersampling. Make sure that SteamVR is not set to more than 100% and that the option from SteamVR to be automatically on top is deactivated.

    Use a tool to see the real load on GPU and CPU like fpsVR or MSI Afterburner. In Afterburner you are able to analyse your session and look for the load on single CPU cores not on the sum because if one core can't handle it's load the complete performance is reduced.
    Also background tasks like some chat or screen recording software is using a lot of the performance that you have to consider while dialing in the settings.
     
    • Like Like x 4
    • Agree Agree x 1
    • Winner Winner x 1
    • Informative Informative x 1
  10. jpmmuc

    jpmmuc Active Member Reiza Backer

    Joined:
    Aug 29, 2016
    Messages:
    172
    Likes Received:
    59
    Check if motion smoothing is disabled and check if your supersampling setting is at 100%, sometimes after a SteamVR update this options are reset.
     
  11. torsteinvh

    torsteinvh New Member Reiza Backer

    Joined:
    Jul 3, 2019
    Messages:
    8
    Likes Received:
    1
    Motion smoothing is disabled, and SS is at 100%.
    Whats strange is that the FPS seems locked to 45. Not varying between say 40 and 50 like I would imagine it would with too high settings...

    And it doesn't feel like 45 FPS either, it feels smooth like 45 FPS reprojected. It's like Steam have introduced a secret, hidden reprojection mode for the Vive Cosmos...

    I'll have to do some systematic testing tonight and see if I can make sense of this.
     
  12. White Oak Racing

    White Oak Racing Member Reiza Backer

    Joined:
    Mar 11, 2016
    Messages:
    36
    Likes Received:
    8
    Posted this on another forum --- but I need help - I can't seem to get a clear picture on my Oculus Rift S. This is my second try at VR - tried 3 months a ago, but got sick and couldn't spend the time on it so I sent it back. Just got the new one today and still really can't get a clear picture.

    I have set my file graphicsconfigopenvrdx11.xml to the following
    <prop name="SharpeningStrength" sharpeningstrength="2.900000" />
    <prop name="SharpeningClamp" sharpeningclamp="0.090000" />
    <prop name="OffsetBias" offsetbias="1.000000" />
    but I need to squint for the picture to be clear - using glasses under the headset seems to make little or no difference - I use readers for computer work - 1.5 strength - so my eyes are not too bad (I'm 70 years old).
    The picture is clear only directly in the middle. All other areas are not sharp at all. The picture on the monitor is fine.
    I'd appreciate any advice, assistance. I really want to use VR. My triple screen setup is failing - two of the monitors are exhibiting problems so it's cheaper to use VR also.
    Thanks in advance for your help. I apologize in advance also for any ignorance I am demonstrating!
    I think my signature has all the pertinent hardware details.
    John
     
  13. jpmmuc

    jpmmuc Active Member Reiza Backer

    Joined:
    Aug 29, 2016
    Messages:
    172
    Likes Received:
    59
    For sharpness of picture
    1st to make sure is that the lenses are exactly at the middle of your pupils left-right and up-down.
    This needs to have the right IPD set and Rift S has as far as I know a fixed IPD of 63.5mm. So if you IPD differs you will not be in the sweet spot of the lenses. Also the height is important.
    Unfortunately the picture is really only sharp if you look straight through the middle of the lenses, if you are looking angled (looking only with the eyes without moving the head) the picture gets blurred if you are looking more to the edge.

    2nd Don't set the sharpening to high for me 2.9 is way to high, try around 0.8 to 1.2. A higher setting will ad more noise. Reduce all graphics settings which blur the picture like all Visual FX settings (best set all to off maybe some crepuscular rays for nice sunlight). For sure disable Motion Blur and Post AA to off.
     
  14. YoLolo69

    YoLolo69 Active Member

    Joined:
    Mar 16, 2020
    Messages:
    181
    Likes Received:
    71
    That's not the good file for an Oculus Rift S, this one is for SteamVR user with E.g. Valve Index or Vive headset.

    The good file to put your settings is graphicsconfigoculusdx11.xml

    You'll see a difference for sure: :)
     
    • Like Like x 3
  15. White Oak Racing

    White Oak Racing Member Reiza Backer

    Joined:
    Mar 11, 2016
    Messages:
    36
    Likes Received:
    8
    Thanks for the help.
     
  16. lensman45

    lensman45 New Member

    Joined:
    May 20, 2020
    Messages:
    19
    Likes Received:
    10
    Agreed. I have Rift s and have sharpeningstrength set to 1.5. Super sampling in-game set to 1.2, MSAA at medium and trilinear filtering on. This gives me a nice crisp detailed image with good frame rates. VR headsets focus to about 2.5 - 3 metres so if you see ok at that distance without specs you should be good to go. As mentioned the ipd is fixed but there is a software adjustment, so get that set correctly.
     
    • Like Like x 1
  17. InfernalVortex

    InfernalVortex Active Member

    Joined:
    May 10, 2020
    Messages:
    287
    Likes Received:
    143
    Guys, I rolled back to an older video card driver (442.50) and this stutter disappeared entirely. This is with an Odyssey Plus/WMR with an nVidia 2070 Super, just in case anyone else stumbles across this.
     
    Last edited: Jul 3, 2020
    • Like Like x 2
  18. MarcG

    MarcG Active Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    354
    Likes Received:
    181
    Clouds are an FPS killer for me, this was known during Beta when it crept in during that period (early Beta was just fine), clear/sunny is about all I can run now with everything on Low/Off which is a shame, I may try and tweak some more though.
    I also noticed a drop in FPS with Online vs Offline strangely!
     
    • Informative Informative x 1
  19. Kurupt CDN

    Kurupt CDN Member Reiza Backer

    Joined:
    Mar 11, 2016
    Messages:
    60
    Likes Received:
    13
    I've come across a few issues that I can't solve and looking for some suggestions.
    I5 9600kf @5.1ghz 1660ti 6gb 16gb Ram and a WMR Lenovo explorer.
    I've lowered the experience in the WMR portal from 90hrz to 60hrz as my card is not powerful enough to run smoothly at 90hrz.
    With my current settings and 20ai the card is using 60-80% usage at 75c and the CPU is around 65% at 55c.
    I've been using vrFPS app and have noticed a few things.
    1. When loading into a session and the splash screen displaying the drivers and session info is visible my GPU jumps up to 95%+ on pretty much every track, pause menu does the same and fps drop. Once I jump into the vehicle it will drop down 60-70% usage.

    Issue 2. Every track in several places, same spot every lap I get a stutter which appears as an orange line in vrFPS. GPU is never over 75% usage or above 75c when it happens and CPU is is under 65% & always around 55c.
    Dropped frames will show up as a red line which appear Everytime I pause or toggle through the menus.

    I've tried several other racing titles in VR and only have this issue in AMS2/PC2.
    The card shouldn't be overheating as it says it's target temp is 83c in MSI afterburner.
     
    • Agree Agree x 1
  20. Kiryu

    Kiryu New Member

    Joined:
    Apr 21, 2020
    Messages:
    20
    Likes Received:
    15
    I have the same issue in VR on some tracks, a small stutter always happening at the same corners.

    Could be that the game loads too many assets at once and this might only be noticeable in VR, since it is already much more stressful on the system.

    Other than that the game runs amazingly well in VR though, even with lots of AI.

    If others have this problem too, maybe you could gather some information on that so Reiza could optimize certain spots on specific tracks a little bit.
     
    • Like Like x 3

Share This Page