1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wheel no longer recognised

Discussion in 'Automobilista - Help & Support' started by still_guns, Apr 18, 2016.

  1. still_guns

    still_guns New Member

    Joined:
    Mar 19, 2016
    Messages:
    17
    Likes Received:
    1
    I bought a wheel especially for Automobilista. It worked before, but when I tried using it again today, the game wouldn't recognise my inputs. The wheel is working perfectly, as the control panel tests check out. But whenever I try and use it for AMS, I keep hearing the device disconnect sound, and the wheel does nothing.

    The wheel is a Speedlink Drift OZ if that helps.
     
  2. still_guns

    still_guns New Member

    Joined:
    Mar 19, 2016
    Messages:
    17
    Likes Received:
    1
    I use Direct Input on the wheel. It has Xinput aswell, which makes it identify as an XBox controller, but it becomes prety much uselss that way, because the paddle shifters share the same axis as the throttle and brake pedals.

    Also, stupid 5 minute editing rule. I shouldn't have to make a second post if I have something to add.
     
  3. Thiago Izequiel

    Thiago Izequiel ex-staff member Reiza Backer

    Joined:
    Mar 7, 2016
    Messages:
    311
    Likes Received:
    187
    Hi! Can you please tell us the period that your wheel was working?
    Also, are you using the beta version or the EA version?
     
  4. still_guns

    still_guns New Member

    Joined:
    Mar 19, 2016
    Messages:
    17
    Likes Received:
    1
    I am using the Steam-bought EA version. The wheel worked from 1st April and was last used on April 8th, when I last played AMS before the 0.8.9r version
     
  5. still_guns

    still_guns New Member

    Joined:
    Mar 19, 2016
    Messages:
    17
    Likes Received:
    1
    FYI, I'm still having this problem
     
  6. Renato Simioni

    Renato Simioni Administrator Staff Member

    Joined:
    Feb 14, 2016
    Messages:
    2,466
    Likes Received:
    11,663
    I´ve set up a branch for v0.8.7 (from March 28th) on Steam, it´s available by right-clicking AMS on Steam -> Properties -> BETAS tab, selecting v0.8.7 from the dropdown box. Could you (and anyone else who may have a similar issue) please try reverting to that and confirm whether the wheel works with that?
     
  7. still_guns

    still_guns New Member

    Joined:
    Mar 19, 2016
    Messages:
    17
    Likes Received:
    1
    Reverted to 0.8.7 and the wheel works again. I suspect the FFB changes in 0.8.9 had something to do with the wheels failure
     
  8. Renato Simioni

    Renato Simioni Administrator Staff Member

    Joined:
    Feb 14, 2016
    Messages:
    2,466
    Likes Received:
    11,663
    OK this is useful, thanks!

    Anyone having similar problems with controllers not being recognized in recent versions, please feel free to try to temporarily revert to v0.8.7 as described above to test if this solves your issues.
     

Share This Page