1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Automobilista 2 V1.4.1.0 Released - Now Updated to V1.4.1.3

Discussion in 'Automobilista 2 - News & Announcements' started by Renato Simioni, Aug 27, 2022.

  1. sgsfabiano

    sgsfabiano Well-Known Member Reiza Backer

    Joined:
    Oct 28, 2019
    Messages:
    1,530
    Likes Received:
    933
    Pretty much. Since day zero someone comes here, post his/her issue, and people go and tell them to delete things.

    And at some point Reiza said it wouldn't be necessary anymore, but people still go with this delete everything workaround.
     
    • Agree Agree x 3
  2. AdrianJ

    AdrianJ Active Member

    Joined:
    Sep 2, 2022
    Messages:
    209
    Likes Received:
    54
    Hi I’m new here
    Is there a dev blog update every month ?
    Is there a sept one ?
     
  3. Jugulador

    Jugulador Well-Known Member

    Joined:
    Apr 1, 2020
    Messages:
    571
    Likes Received:
    336
    Will be... the September devblog will probably came in November
     
    • Like Like x 1
  4. Theodore Schultz

    Theodore Schultz Active Member

    Joined:
    Jun 3, 2022
    Messages:
    241
    Likes Received:
    132
    Have them verify first
     
    Last edited: Sep 14, 2022
    • Like Like x 1
  5. Demichkd

    Demichkd Member

    Joined:
    Jan 1, 2021
    Messages:
    75
    Likes Received:
    50
    I had the exact same issue with Mini JCW, other cars were fine. I couldn’t hear my engine audio but could hear opponents.

    All I did was adjust all audio settings up one tick in AMS2 to save settings and went into Windows Sound Settings and deselected and reselected everything to again get a fresh save and it worked.
     
    • Agree Agree x 3
    • Like Like x 1
  6. Marc Collins

    Marc Collins Well-Known Member Reiza Backer

    Joined:
    Mar 12, 2016
    Messages:
    5,250
    Likes Received:
    2,279
    Yes, if there is a problem with a piece of content or a function of the game itself, then a Steam file integrity check is the first step.

    BEFORE REINSTALLING AMS 2, DECIDE IF IT IS WISE/WORTH YOUR TIME
    If there is a problem with something that users can configure (e.g., FFB, car set-up, audio settings that affect all cars, controller settings, etc.), then the first step is to reset the item back to default or even just change a setting. We saw that simply selecting a tire in the garage set-up fixed a strange temporary bug with the F-Trainer. Resetting the garage set-up using the menu is still a wise idea if you are having an issue with a car and other people claim it works perfectly.

    If you have a problem that affects ALL cars or tracks, then try changing the appropriate related settings in the game's menu, first.

    If all that fails, then you can chose to delete individual files related to the problem area. For example, deleting the ffb_custom_settings.txt file will force the game to create a new one with the minimalist FFB that accompanies the Default and Default+. You can replace the custom file with an actual downloaded custom profile if you like, but best to test things with the standard defaults if there is a problem.

    If that doesn't work, you can delete the default.controllersettings.v1.03.sav file and the game will create a new one forcing you to reconfigure your controllers.

    If all that doesn't work, then you could delete your entire Automobilista 2 user folder (in \Documents), but why would you do this tedious exercise unless just about everything in your game was messed up? Odds are if you are having a problem it is with one individual item that can be deleted so the game will create a fresh one. The only files I can imagine ever touching to force a reset are:

    ffb_custom_settings.txt

    In \Profiles
    default.controllersettings.v1.03.sav
    default.localsettings.v1.03.sav
    default.championshipeditor.v.100.sav
    default.sav

    The \vehiclesetups folder if I want to be 100% sure no old set-ups are still lurking.

    Anyone who spends the time to delete the entire Automobilista 2 folder is simply resetting all of these things at once, to solve a problem with likely one of them at the most.

    Reinstalling the entire game is completely pointless other than if you also delete the Automobilista 2 folder from \Documents to ensure that the new install is not picking up anything from the prior installation. Of course, you can accomplish exactly the same thing with a Steam integrity check and deleting the Automobilista 2 folder and save yourself a bunch of time and bandwidth.

    I have yet to read a message from anyone who has kept parallel installations that allow toggling back and forth to prove whether there is a difference between them. Any differences that are experienced are a result of one of the above items being reset/reconfigured, which can be accomplished with a Steam file check and selective deleting of files.

    There are many thousands of us who have never reinstalled or deleted our user folder and our games work as expected--meaning not necessarily perfectly if there are known issues or bugs like the F-Trainer tire selection bug, which when overridden still leaves us with a WIP F-Trainer tires that are not up tp the standards of most of the other cars in the game.

    Reinstalling, deleting, reconfiguring or staring at a blank wall for an hour all have an equal chance of curing the F-Trainer of its issues, since that will require Reiza to complete their work on the update to this car. Any problem that affects individual cars or tracks or series and not the entire game is by definition not a candidate to be fixed by a general reset or reinstallation. The problem is either in the garage set-up (reset or fiddle with it), or, it's part of the game and we have to wait for Reiza to fix it or live with it (e.g., the SuperV8 fast ratio steering that makes it more difficult to get balanced FFB on that particular car). But if one or two vehicles have unpleasant FFB, but the rest are fine, the problem is not with your installation of AMS 2. If a few cars understeer or handle poorly, but the rest are fine, the problem is not with your installation of AMS 2. It could be garage set-up related for those vehicles, but it is not a systemic issue unless ALL cars have the problem. And even if ALL cars have an issue, the odds are much higher that it is a design or programming issue or a FFB configuration problem rather than a general installation issue.
     
    Last edited: Sep 14, 2022
    • Agree x 10
    • Like x 4
    • Informative x 3
    • Winner x 2
    • Disagree x 1
  7. Marc Collins

    Marc Collins Well-Known Member Reiza Backer

    Joined:
    Mar 12, 2016
    Messages:
    5,250
    Likes Received:
    2,279
    I am sure there are many. Have you heard of the hydraulics failing on a race car and it grinds to a halt? This illustrates one reason because the sequential gear lever is hydraulic and not mechanical (like an H-shifter). The latest sequential transmissions work with electronic signals, the most common of which are from steering wheel shift paddles. They don't have a lever at all. Even my road car doesn't have a mechanical shift lever...it just looks like one, but is 100% electronic!
     
    • Informative Informative x 1
  8. Marc Collins

    Marc Collins Well-Known Member Reiza Backer

    Joined:
    Mar 12, 2016
    Messages:
    5,250
    Likes Received:
    2,279
    A great example of fixing a problem by adjusting the related settings (in the game and in Windows!). Always the best first step. And, the best clue for the devs to fix the problem permanently if it is a common bug.
     
    • Like Like x 3
  9. F1Aussie

    F1Aussie Well-Known Member

    Joined:
    Mar 21, 2016
    Messages:
    1,689
    Likes Received:
    487
    I had what I thought were some issues with the super V8 and the Omega 99 but the reinstall did not change them. Prior to reinstall my fanatec display would freeze up, hasn't happened since the reinstall but might just be too early to tell
     
  10. Jugulador

    Jugulador Well-Known Member

    Joined:
    Apr 1, 2020
    Messages:
    571
    Likes Received:
    336
    Sir, my game felt like it was alright because there only a small bunch of cars working weirdly... as this game have soo much content, maybe people had it not working fully as intended and don't even guess that.

    IMHO, everybody has some couple of hours (or even a full night) that can be spent to leaving their PCs downloading AMS2 again. It's only annoying to set all your configs back to the right place again, but considering how friendly all the process is, took me only another five minutes and now it's working fine.

    I recommend people to try if they have the time... if not, maybe Reiza is already working over that and things may fix itself over next updates.

    Here, the SV8 is behaving, as far I can tell, the same as after the last update and before I reinstall.. an amazing car. The Omega I didn't try since 1.2 or 1.3 update and couldn't tell if changed now.

    Couldn't this Fanatec issue be related to the shared memory configuration? The Crew Chief app is and I didn't try it again nor changed this setting back to what would be because I forgot if I need to use PCARS 1 or 2.. but will do some try tomorrow.
     
    • Agree Agree x 2
  11. F1Aussie

    F1Aussie Well-Known Member

    Joined:
    Mar 21, 2016
    Messages:
    1,689
    Likes Received:
    487
    I wish I could say the same about the super V8, still something a little off with it. The display issue I think has been reproduced by fanatec so will have a fix at some stage. I had PC2 as the setting for shared memory, is that wrong?
     
    • Like Like x 1
  12. Dicra

    Dicra Local Gamepad Ambassador

    Joined:
    May 1, 2020
    Messages:
    604
    Likes Received:
    414
    Tbh these constant water-to-wine tales because of the mythical reinstall are, in my opinion, just the racing sim variant of the placebo effect.
     
    • Agree Agree x 6
    • Disagree Disagree x 1
  13. tennenbaum

    tennenbaum New Member

    Joined:
    Jul 6, 2022
    Messages:
    3
    Likes Received:
    8
    @Marc: Good comment.
     
    Last edited: Sep 14, 2022
  14. Simmo99x

    Simmo99x Active Member

    Joined:
    May 13, 2020
    Messages:
    217
    Likes Received:
    116
    I think there's a major problem with the Super V8, as mentioned before it feels great now in most aspects but the self aligning is none existent, just wandering all over the track
    Not sure if its a default setup problem or just broken.
    Shame because the V8 wagon is probably one of the best feeling in AMS 2 imo.
    Also is there a cure for the flickering shadow under the cars in replay mode please.
    Tried settings on min and ultra same issues.
     
    • Like Like x 1
    • Agree Agree x 1
  15. Dicra

    Dicra Local Gamepad Ambassador

    Joined:
    May 1, 2020
    Messages:
    604
    Likes Received:
    414
    Yes. This. This could be one of the best car in the sim and instead it's just a chore to drive because it constantly turns even when it's got no reason to.

    Pretty sure it's just broken, because there's no other car in the sim I've ever managed to make feel like that, no matter what I changed about the setup.
     
    Last edited: Sep 14, 2022
    • Agree Agree x 1
  16. Troodon

    Troodon Active Member

    Joined:
    Apr 8, 2021
    Messages:
    134
    Likes Received:
    67
    I did a test out of idle curiosity the other day. I made a full copy of the Steam installation folder of AMS2, uninstalled the game and checked that nothing remained of the Steam folder. I then reinstalled and compared the newly downloaded folder with the copy from before with WinDiff. They were completely identical.

    I'm pretty sure that the previous installation was from the end of 2020, maybe moved to a different drive and file integrity verified a couple times. If the game's installation folder was somehow broken over time I would expect it to show by now. I don't believe that wiping and redownloading that folder does anything.

    A modded game (mine was not) might be an exception to that in some ways, but AFAIK the files you change inside the Steam folder aren't ones that would break car handling.

    The only other relevant place I can think of beyond My Docs and the Steam folder is the Windows registry. There was a Steam discussion I saw that claimed AMS2 changed FFB-related registry values and broke FFB globally for one user with a G29 (which is the wheel/pedals that I use without issues). I wish I had taken full registry dumps from all parts of the process.

    It is also possible that the problems just had not popped up on my system. In any case, I'd go with what Marc is saying. Try resetting the relevant settings/files before more drastic measures. I'd encourage people to try one small fix at a time and to precisely document what they're doing - which setting/file, what the original values were, what they were changed to, what the result was. At the moment there's a lot of "I reinstalled everything" going on. While it may be effective, it also makes it hard to pinpoint the thing that actually made a difference.
     
    • Like Like x 2
    • Winner Winner x 2
    • Informative Informative x 2
    • Agree Agree x 1
  17. ayrton2388

    ayrton2388 New Member

    Joined:
    May 10, 2022
    Messages:
    22
    Likes Received:
    13
    I saw your video and decided to give those cars another go... and something really strange happened :|
    F V12 cars are perfectly fine and drivable cars now, totally different than last time i played, 3 weeks ago.

    What i did both now and back then was to reset the setup, go max downforce on both front and rear wings, and max out the steering lock (I run shorter, less famous circuits). Now, they handle perfectly fine. I don't know if the last couple of updates changed anything, or at the very least reset my setups or something, but it's a huge difference, and i'm not crazy, i can tell you specifically where and how the car behaved wrong...

    For example, on Londrina, when braking down for the chicane, 80% of the time the car would spin under braking. On the left turn after the straight, the car would understeer and slide off the track.
    On Taruma, the car would slide off the track in the first two corners, which i was able to take flat out before. On Guapore, same thing, there was a fast right corner i was taking flat out before, but would slide off the track after 1.3.8 and 1.4. And when i mean "sliding off the track", i don't mean just understeer, i mean that all 4 wheels felt like they were sliding / losing contact with the track. None of those things happened before 1.3.8.

    Anyway, i just wanted to post here to say that F V12 are actually ok now, played a few hours last night and had a blast. World was restored back to normal :D that was a really strange issue, though. What can i say, i'm glad it somehow got fixed.

    Also, DTM M3 car, omfg... i couldn't drive that thing before, now i love it! So, so much fun, can't wait to give that another go tonight.

    Thanks for taking the time to look into the F V12, Maser.
     
    • Like Like x 3
  18. Maser V6

    Maser V6 Assume nothing._ Verify everything._Have fun Reiza Backer

    Joined:
    Mar 27, 2020
    Messages:
    2,396
    Likes Received:
    1,344
    Your welcome.
    '
    re V8 is also fine here default.
    Have fun
     
    Last edited: Sep 14, 2022
  19. Dady Cairo

    Dady Cairo Our man for the rough Reiza Backer

    Joined:
    Jun 12, 2017
    Messages:
    1,648
    Likes Received:
    579
    Because it's not the truth!
     
    • Like Like x 1
  20. Rhosta

    Rhosta Gyro Controller User

    Joined:
    Jul 25, 2022
    Messages:
    13
    Likes Received:
    4
    I had to do the same thing for controller button mapping in demo. The button mappings appeared correct in the menu, but I had to assign them again to make them work.
     

Share This Page