1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Connection Lost

Discussion in 'Automobilista Discussão em Português' started by Paulo Toledo, Oct 1, 2017.

  1. Joao Felipe Oliveira

    Joao Felipe Oliveira New Member

    Joined:
    May 16, 2018
    Messages:
    1
    Likes Received:
    0
    Prezados, comecei a enfrentar esse problema, justamente ao trocar a Vivo pela NET. Já houve solução para isso? Estou na versão 1.5.11.
     
  2. Dann Murillo

    Dann Murillo League Organizer: onlinesimracing.net Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    433
    Likes Received:
    219
    Bump. I have this same problem.

    In v1.4.8 this was added:

    • Added regular silent messages by clients in multiplayer (as a possible fix for TCP connection lost issues with client inactivity)
    Automobilista v1.4.8 RELEASED, now updated to v1.4.81

    But I am curious if that coding possibly got removed? I got kicked out of any server nowadays and it has been going on for a few months. The workaround I mapped blank autochats to my shifters to stay connected and this certainly works but I still lose connection if I sit in my garage or am idle for too long.

    I reinstalled windows and AMS completely. Perhaps it is my ISP but I am on my 3rd modem and it did this with all of them. Also my internet connection does not actually drop nor does anyone else in my house lose connection in games like Fortnite or Apex.

    I can spectate to race all day without issues but when I am an actual driver I lose connection every time I am idle for more than a couple minutes.
     
  3. Domagoj Lovric

    Domagoj Lovric Moderator Staff Member

    Joined:
    Feb 15, 2016
    Messages:
    524
    Likes Received:
    302
    Code is still in place. Messages are transmitted every 30sec.
    What is transmits time interval for your blank autochats ?
     
  4. Dann Murillo

    Dann Murillo League Organizer: onlinesimracing.net Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    433
    Likes Received:
    219
    My blank autochats are set to transmit every time I shift up or down. It really works too. I can stay connected to a server for hours as long as I am constantly driving and shifting. But then if I am idle for more than a couple minutes or so, I will be disconnected.

    The way AMS disconnects me is when I click drive (after I have been idle for too long) after maybe a few seconds or even up to like 30 seconds it will say "connection lost" then if I do not manually leave the server and leave the game it will automatically go back to the main menu and start like swelling all of the words and icons. It is very odd. I have another driver this has happened to since the start. His handle is Vector so we call this the Vector virus. lol

    [​IMG]
     
  5. Edilson Freshi

    Edilson Freshi Member Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    38
    Likes Received:
    6
    Olá pessoal, um colega me recomendou uma solução para o problema de Connection Lost, que no meu caso resolveu. Mudar o modem da NET do modo "Router" (Roteador) para modo "Bridge" (Ponte), precisa de um outro roteador nesse caso que irá fazer o trabalho de roteamento da rede e distribuição dos IPs (DHCP). O cabo de rede que sai do modem é ligado na porta WAN do roteador, pra mim resolveu.. fica a dica pra quem quiser tentar, há vários tutoriais na internet ensinando a fazer essa mudança.

    Hi guys, a friend suggest me a posible solution for this case, and it works for me, I don't have "Connection Lost" issue anymore. The solution was change the cable modem mode from "Router" to "Bridge" and install another router on my network to do the "routing" and IP distribution (DHCP) jobs. The network cable from the modem need to be plugged on WAN port on router. There is some tutorials on the internet explaining this process.
     
    Last edited: Apr 30, 2019
    • Like Like x 3
  6. Dann Murillo

    Dann Murillo League Organizer: onlinesimracing.net Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    433
    Likes Received:
    219
    WOW, who would have thought this was the solution? This instantly solved my months of "connection lost" issues. I changed my modem to bridge mode and added a router. I can now stay connected to servers for hours.

    @Domagoj Lovric FYI ;)
     
    • Like Like x 3
  7. Rodrigo de Sousa

    Rodrigo de Sousa New Member Reiza Backer

    Joined:
    Jul 26, 2019
    Messages:
    3
    Likes Received:
    1
    I discovered this by myself. After a lot of problems with connection lost, I searched in google about connection issues and tried this solution and it worked. I'm glad it helped you :D
     
    • Like Like x 1
  8. Silvio Cividini

    Silvio Cividini New Member

    Joined:
    Oct 1, 2017
    Messages:
    6
    Likes Received:
    0
    Boa tarde. Eu tinha um link da copel e mudei de endereço, acabei optando por um da NET. Na primeira semana corri sem problemas mas agora está acontecendo o mesmo que outros já relataram aqui, dá alguns minutos e caio do servidor. Tentei a solução de mandar um autochat mas não resolveu. Alguém descobriu se o problema é mesmo dos modens da NET?
     
  9. Heitor Facuri Cicoti

    Heitor Facuri Cicoti Good Member Staff Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    469
    Likes Received:
    220
    @Silvio Cividini, a resposta do Edilson Freshi não te ajudou?

     
  10. Wedsley Dias

    Wedsley Dias Member

    Joined:
    Mar 10, 2016
    Messages:
    74
    Likes Received:
    46
    @Silvio Cividini @Heitor Facuri Cicoti - Aqui mais um usuário recém migrado para a Net e assim como muitos outros, enfrentando o mesmo problema. Me parece que a causa é realmente o router da Net, já que encontrei vários usuários Net com esse problema e não só no AMS.

    Não tem outra solução? Só adquirindo outro roteador deixando o da Net em bridge?
    No meu caso é triste porque o router da Net fica ao lado do PC (único dispositivo que usa conexão via cabo), o resto da casa tudo wifi e neste modo o router já atende bem.

    Att.
     
  11. Heitor Facuri Cicoti

    Heitor Facuri Cicoti Good Member Staff Member Reiza Backer

    Joined:
    Mar 8, 2016
    Messages:
    469
    Likes Received:
    220
    Pois é, Wedsley, eu não tenho muito mais informação sobre esse problema além do que já está neste tópico. Parece que não há outro jeito mesmo.
     
    • Like Like x 1
  12. Allan Hellmann

    Allan Hellmann New Member Reiza Backer

    Joined:
    Sep 29, 2017
    Messages:
    1
    Likes Received:
    0
    A solução já apresentada no RD (losing my connection after some minutes - Latest Formula 1, Motorsport, and Sim Racing News) resolveu para mim, que tenho um modem da Vivo (ainda da época da GVT). Eu coloquei uma bind para o botão de passar marcha pra frente para mandar um chat privado para mim mesmo (/w meunome "") e não tenho problemas, isto é, enquanto estou pilotando. Por outro lado, é só ficar parado no pits por alguns minutos que desconecta. Seria ótimo ter uma solução por parte da Reiza para este problema que afeta a tantos, nem que seja simples como enviar uma mensagem que não aparece no chat periodicamente (eu vi que já foi implementado algo parecido, mas como estamos tendo esse problema até hoje, vemos que não resolveu), uma vez que o desenvolvimento está focado no Automobilista 2. Eu já desisti de dois campeonatos (que paguei inscrição e treinei horas) por causa dessas disconexões, e conheço várias pessoas que desistiram totalmente do jogo por causa desse problema, que nunca foi solucionado, o que é uma pena. Seria possível termos uma solução, mesmo que simples?
     
  13. Wedsley Dias

    Wedsley Dias Member

    Joined:
    Mar 10, 2016
    Messages:
    74
    Likes Received:
    46
    Com acesso ao código e o problema sendo específico dessa engine, poderiam dar um pouco de atenção a isso, considerando vários relatos dentre eles o último do @Allan Hellmann e a sugestão de um paliativo (bind) que não se enquadra/funciona em todos os casos.
    Sabemos que o foco agora é o AMS2 e outras frentes de trabalho, mas não acredito que o AMS vai morrer depois do lançamento do seu sucessor, considerando que há ainda alguns meses até o seu lançamento e também porque o AMS ainda vai continuar na prateleira com preço mais acessível.
    Então fica a pergunta para a equipe @Heitor Facuri Cicoti , @Domagoj Lovric , @Renato Simioni : Podemos ter a esperança que esse problema seja resolvido? Obrigado.
     
    Last edited: Aug 20, 2019
  14. Felipe husmann

    Felipe husmann New Member

    Joined:
    Aug 26, 2019
    Messages:
    5
    Likes Received:
    0
    Uma pena um jogo tão bom ser abandonado desse jeito. Eu queria participar de uma liga mas infelizmente não posso com esse problema irritante. Quando lança o AMS 2 vou ficar na dúvida se compro ou não, devido a esse descaso com os clientes do AMS.
     
    • Funny Funny x 1
  15. Dann Murillo

    Dann Murillo League Organizer: onlinesimracing.net Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    433
    Likes Received:
    219
    Do you guys know they have tried to fix this problem (which has been around since the start of RF1) by adding micro whispers? They have not abandoned or neglected anything - they have tried to fix the age old problem. The real problem is modems with routers built into the one device. Once I purchased a better router my whole house has better internet, both wired and wireless, and I never lose connection to any AMS servers.;)

    In v1.4.8 this was added:

    • Added regular silent messages by clients in multiplayer (as possible fix for TCP connection lost issues with client inactivity)
    Driver v1.4.8 RELEASED, now updated to v1.4.81
     
  16. Felipe husmann

    Felipe husmann New Member

    Joined:
    Aug 26, 2019
    Messages:
    5
    Likes Received:
    0
    Muito errado tentar passar o problema do jogo ao cliente. Agora terei que trocar de modem ? Nunca precisei trocar de modem em 15 anos de jogos online por um problema do jogo.
     
  17. Dann Murillo

    Dann Murillo League Organizer: onlinesimracing.net Reiza Backer

    Joined:
    Mar 9, 2016
    Messages:
    433
    Likes Received:
    219
    FYI, I don't work for Reiza, I'm just telling you how I fixed the problem.

    You have a 15 year old modem / router combo? WOW!
     
  18. Felipe husmann

    Felipe husmann New Member

    Joined:
    Aug 26, 2019
    Messages:
    5
    Likes Received:
    0
    Já tive vários modens durante 15 anos e nunca tive problemas com jogos.
     
  19. Domagoj Lovric

    Domagoj Lovric Moderator Staff Member

    Joined:
    Feb 15, 2016
    Messages:
    524
    Likes Received:
    302
    For upcoming update, we have halved "silent message" interval and increased it's priority in message queue.
     
    • Like Like x 1
  20. Felipe husmann

    Felipe husmann New Member

    Joined:
    Aug 26, 2019
    Messages:
    5
    Likes Received:
    0
    Excelente noticia. Agradeço pela resposta.
     

Share This Page