1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logitech G29 centering issue.

Discussion in 'Automobilista - Help & Support' started by choi, Nov 29, 2019.

  1. choi

    choi New Member

    Joined:
    Nov 29, 2019
    Messages:
    5
    Likes Received:
    0
    Good day.

    I just bought AMS yesterday and I have played 2 hours?
    Well, technically I could not played at all.
    Cause my goddamn g29 seems like he doesn't want to work properly.
    When the car is stationed at pitbox, then I turn the wheel from side to side? It just coming to the center.
    But I mean that in real life the car doesn't make the steering wheel rotate itself when its parked right?
    it's not Tesla auto pilot or something it's damn racing sim

    Here is what I did :
    Turned off 'Center spring option' in 'G Hub'
    Have changed thousand of option for force feedback strength and low force boost.

    I have 'Zero' problem with 'Pcars, AC, Dirt rally, rF1,R3E' at all!

    EXCEPT AMS...

    If I turn the wheel when car stops, it suppose to at the position where I let it be right?

    Can someone has solution ?

    Apologize for bad english

    update.1 19-11-30 00:21
    I have tested several version.
    Seems these two versions are work well.[No centering spring]
    The others not tested yet.

    v1.5.16
    v1.4.93

    update.2 19-12-01 00:45
    I have tested all the other version of AMS
    And here is result

    v1.4.8_g29
    v1.4.76
    v1.4.7_g29
    v1.4.54

    Version above work fine.

    I really hope that solve the problem and enjoy real racing sim soon...

    update.3 19-12-05 17:49
    Suddenly it works fine.
    What I've done is install and delete many version of LGS includes G hub and test it out(no in-game options changed).
    And then the wheel has no centering spring force even right after turn on while I don't play any games yet.
    I have no idea what is going on my wheel though.
     
    Last edited: Dec 5, 2019
  2. Anton

    Anton New Member

    Joined:
    Nov 30, 2019
    Messages:
    3
    Likes Received:
    0
    I have the exact same issue. Force Feedback does not work with my G29 in AMS 1.5.3 or 1.5.25, but works well in 1.5.16.

    My G29 is fairly new, purchased about 6 weeks ago. I purchased AMS in the Steam sale yesterday, since then I have been struggling to get the FFB working. Running it on Windows 10.

    Symptoms are: the wheel has a very strong centering spring, present when the car is stationary, and which does not vary at all while driving; it makes steering an almost impossible arm-wrestle. Setting "Force Feedback Strength" to a large positive value inverts this, so the return force then decreases with displacement from centre (this is easier to drive, but silly). Effects such as bumps and collisions are felt, so the game is able to send some FFB signals to the wheel.

    The RealFeel Console shows the session is initialised for the selected car, and then 20 or 30 lines of numeric data that presumably represent the FFB commands being sent to the driver. However, there are never any more of these lines generated after the first few.

    I'm using the latest GHUB (spit) software from Logitech.

    My theory is that RealFeel is crashing very soon after I sit in the car, possibly due to an incompatibility with the latest Logitech drivers.

    I'm happy to help investigate this further, if someone can suggest a way to do that (I'm a software engineer).

    Seems like a fairly serious bug, since it will prevent new G29 owners from enjoying the "final" AMS version, unless we can find a workaround.
     
  3. choi

    choi New Member

    Joined:
    Nov 29, 2019
    Messages:
    5
    Likes Received:
    0
    God, [I'm sorry to say that But..] I'm glad you to say that.
    I thought that I'm the only one who has a problem.
    at least its not only MY problem so the developers can investigate this.

    Yeah, I read that news too, its 'final' hotfix. So I was afraid that developers not going to do some investigate anymore.

    I bought my G29 1 week ago.
    And I adjust 'Force feedback strength' in every way.
    But no progress.

    I'll test another version of AMS.
    I'll post it when its done.
     
  4. Michael Enright

    Michael Enright New Member

    Joined:
    Jul 3, 2019
    Messages:
    9
    Likes Received:
    0
    Had the same issue with G27. All was solved, for me anyway, with, v1.5.3r. Found this info that may help. This helped me before the latest version.
    "Yep we´re aware of the issue with any mod car that uses SteeringFFBMult = 0 in HDV will have no FFB. This is a result of the fix added for direct drive wheels (in fact that value should never be 0 in AMS )."
    Try 2.0 Unfortunately if it works, you have to change each car you drive individually. Hope this helps.
     
  5. Domagoj Lovric

    Domagoj Lovric Moderator Staff Member

    Joined:
    Feb 15, 2016
    Messages:
    524
    Likes Received:
    302
    Hello all,

    Here is first step to figure this out, trace files:
    Posting Trace files

    Thanks all!
     
  6. choi

    choi New Member

    Joined:
    Nov 29, 2019
    Messages:
    5
    Likes Received:
    0
    Here is my trace file.
    I turned wheel one or two times at the pit box then I drove a car just before the pit exit.
    And I don't use realfeel things or mod
     

    Attached Files:

    Last edited: Nov 30, 2019
  7. choi

    choi New Member

    Joined:
    Nov 29, 2019
    Messages:
    5
    Likes Received:
    0
    I don't have any 'mod' car.
    And I don't get that means 'Try 2.0.
     
  8. Anton

    Anton New Member

    Joined:
    Nov 30, 2019
    Messages:
    3
    Likes Received:
    0
    Thanks Domagoj. Here is my trace, I drove an Utima GTR out of the pits and through the first few corners at Donington.

    My G29 is recognised as "Logitech G HUB G29 Driving Force Racing Wheel". AMS was unable to import a profile for it automatically, perhaps because it was expecting just "G29". Not sure if this is significant.

    Michael, thanks for your suggestion, I don't think SteeringFFBMult is the problem here though. I'm not running any mods, have a fresh Steam install only a couple of days old. The patch notes for AMS 1.5.3 say:

    Added a hardcoded SteeringFFBMult value so a car will still have Force Feedback even if value is missing or zeroed in its physics file

    so it looks like this issue was fixed in 1.5.3 anyway.

    Let me know if there are any more tests or experiments I can do.
     

    Attached Files:

  9. Anton

    Anton New Member

    Joined:
    Nov 30, 2019
    Messages:
    3
    Likes Received:
    0
    Thanks for the update Choi, I'm glad you were able to get it working.

    Please could you let me know which GHUB version you are currently using? I'm on 2019.11.29288, which should be the latest, is this the one that works for you?
     
  10. choi

    choi New Member

    Joined:
    Nov 29, 2019
    Messages:
    5
    Likes Received:
    0
    I'm currently using same version as yours.
    I think that version is the latest?
    And the other versions that I've install and delete many times are :
    LGS 8.70.315
    LGS 9.00.42
    LGS 9.02.65

    G HUB 8.87.116
    G HUB 8.94.108
    G HUB 8.94.108

    Those were for Win 10 64bit
    And I also updated latest version of Win 10 (18xx to 1090)

    I really hope you to fix this issue and can enjoy the sim soon.
    I'll come by to check yours updates or from dev sometime.
     
    Last edited: Dec 7, 2019

Share This Page